jV マニュアル & 使用例

Version 4.5.8, 2021年4月26日

「jV」は、木下賢吾(東北大学大学院情報科学研究科)と中村春木(大阪大学蛋白質研究所)により、日本蛋白質構造データバンク(PDBj)の活動の一環として、独立行政法人科学技術振興機構バイオサイエンスデータベースセンター(JST-NBDC)と大阪大学蛋白質研究所の支援を受けて開発されているプログラムです。

英語版オリジナルマニュアルはこちら。 ユーザーガイドはこちら(PDF)。 jVホームページはこちら(英語版日本語版)。

当サイトの内容は、上記リンク先のオリジナルマニュアルやユーザーガイドの内容に、使用実例などを追加してまとめ、翻訳したものです。

3. 基本的な使い方 トップページに戻る 5. コマンドリスト(カテゴリ別)

4. コマンドリスト

jVのコマンドはRasMolのコマンドに修正を加えたものです。 ここでは、ユーザが値を指定する引数は value のように反転表示し、指定できる値が制限されている引数については off/false のようにスラッシュで区切って指定可能値を列挙して で囲み、省略できる引数は on/truevalue のように 斜体で下線を引いてそのこと示しています。書式についてはヘルプも参照して下さい。

アプレット版ではいくつか利用できないコマンドがあります。そのようなコマンドの説明にはそのことが記してあります。また、こちらにもアプレット版で使えないコマンド一覧を記しています。

4.1.add_backbone

add_backbone 残基名 原子名

特定残基の主鎖構成原子を追加します。原子名にはコンマ区切りで原子名を列挙します。原子名 を省略すると、指定した残基の主鎖構成原子設定は初期状態に戻ります。 何も引数を指定しないと現在の設定状態を表示します。

4.2.anim

anim forward フレーム数

アニメーションを正方向に動かし始めます。 フレーム数 を指定した場合、指定したフレーム数だけ正方向に進めます。

anim backward フレーム数

アニメーションを逆方向に動かし始めます。 フレーム数 を指定した場合、指定したフレーム数だけ逆方向に進めます。

anim stop

アニメーションを停止します。

4.3.animframe

animframe フレーム数 ファイルID

アニメーションファイルのフレーム数をフレーム数で指定した値に設定します。 ファイルID を指定した時は、指定したファイルだけが対象となります。

4.4.animmode

animmode once

アニメーションを繰り返しません。 最後のフレームまで進むとアニメーションは停止します。

animmode loop

アニメーションを繰り返し表示します。 最後のフレームまで表示すると再び最初から表示します。

animmode swing

アニメーションを往復して表示します。 最後のフレームまで表示すると方向を逆転させて表示を続けます。

4.5.animrange

animrange 開始フレーム-終了フレーム ファイルID

アニメーションファイルの動作範囲を開始フレームから終了フレームの間に設定します。 ファイルID を指定した場合、指定したファイルだけが処理対象となります。

4.6.animselect

animselect -a/-r ファイルID

指定したアニメーションファイルの選択、選択解除を行います。-aオプションを指定した場合またはオプションを指定しない場合は指定ファイルが選択、-rオプションを指定した場合は指定ファイルの選択が解除されます。指定ファイル以外の選択/非選択状態は変更しません。コンマで区切って複数のファイルを指定することもできます。

4.7.animspeed

animspeed 速度

アニメーションの動作速度を設定します。 速度は1から20までの整数で指定します。

4.7.animstep

animstep 間隔 ファイルID

アニメーションの表示間隔を指定します。 ファイルID を指定した場合はそのファイルのみ、指定しない場合は全てのファイルが対象となります。

4.9.backbone

メニューの[Display][Backbone]による操作とこのコマンドによる操作は似ていますが、メニューでは選択範囲の表示が主鎖表現(backbone)に「変更される」のに対し、このコマンドでは既存の表示を残したまま主鎖表現が「追記される」点が異なります。既存の表示が空間充填表現(spacefill)などの場合は主鎖表現を追記しても隠れて見えず何も変わっていないように見えますが、ワイヤーフレーム表現(wireframe)などの場合は主鎖だけが変化し追記されたことが分かります。

backbone on/true

選択範囲をバックボーン表示(主鎖のみを線で表示する表示モード)にします。

backbone off/false

選択範囲内でバックボーン表示になっている部分の表示を消します。

backbone 半径

選択範囲のバックボーン表示部分を指定した半径で描きます。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大2.0(Å)または500(ラスモル単位)です。 バックボーン表示にした時の初期値は0.3です。 値を省略すると0.15の太さになります(但し、0.15を指定した時と光の当たり具合が違う)。

  • 例001:分子を主鎖表示にする

4.10.background

background 色指定値

背景色を変更します。 RGB値([r,g,b]、r,g,bはそれぞれ0から255までの値)または既に定義されている色名を使って指定できます。既定値は黒([0,0,0]、black)です。色の記述については、色表現も参照下さい。

4.11.ball_and_stick

ball_and_stick on/true

選択されている原子の表示方法を半径0.5Åの球と半径0.2Åの太さの棒を使った表示に変更します。

ball_and_stick off/false

選択されている原子の中で表示方法が球棒表示に指定されている部分の表示を消します。

ball_and_stick 球の半径 棒の半径

選択されている原子の表示方法を指定した半径球と棒を使った表示に変更します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定可能な最大値は球については3.0(Å)、棒の太さについては2.0(Å)です。

4.12.cartoon

メニューの[Display][Cartoon]による操作とこのコマンドによる操作は似ていますが、メニューでは選択範囲の表示がcartoon表現に「変更される」のに対し、このコマンドでは既存の表示を残したままcartoon表現が「追記される」点が異なります。但し、既存の表現がribbonの場合、追記されたcartoonに隠れて既存のriboonが見えなくなり、変更されたのと同じように見えます。

cartoon on/true

選択した残基を太いリボンで表示します。リボンで表示するのに十分な原子がない鎖については代わりに主鎖表現(backbone)で表示します。

cartoon off/false

選択した残基の太いリボン表示を消します。

cartoon 半幅長

選択した残基を指定した幅が半分となる太さを持つリボンで表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大4.0(Å)または1000(ラスモル単位)です。

  • 例002:リボンの太さを変える

4.13.center

center -r/-s 原子表現

選択している分子の回転中心を表示の中心に移動します。 -r オプションをつけると回転の中心だけが移動します。 -s オプションをつけると表示の中心だけが移動します。 (→原子表現参照)。

  • 例003:中心を移動する
center -r [x,y,z]

指定した値・方向に回転の中心と表示の中心を移動します。 -r オプションをつけると、回転の中心だけが移動します。

center -r {x,y,z}

指定した座標 {x,y,z} に回転の中心と表示の中心を移動します。 -r オプションをつけると、回転の中心だけを指定座標に設定します。

center -s [x,y]

指定した値・方向(x方向(水平方向)またはy方向(上下方向))に表示の中心を移動します。

center -s {x,y}

指定した座標{x,y}に表示の中心を移動します。

4.14.color

color atoms

選択した原子の色を設定します。色はRGB値[r,g,b]、既定の色名、あるいは既定の色スキーム(amino, chain, charge, cpk, group, shapely, structure, temperatureのどれか1つ)で指定します。色設定については色表現も参照のこと。

color bonds/backbone/ribbons/hbonds/ssbonds

指定した対象(結合や表示)の色を設定します。色はRGB値[r,g,b]または既定の色名で指定します。水素結合の色を設定するには色スキーム「type」を指定します。

color bonds/backbone/ribbons/hbonds/ssbonds none

指定した対象(結合や表示)の色設定を初期値に戻します。

4.15.colorvertex

colorvertex

選択した頂点の色を設定します。 色の指定はRGB値 [r,g,b] または既定の色名で行います。

colorvertex none

選択した頂点の色を初期状態に戻します。

4.16.cpk

cpk

spacefillコマンドと同じ働きをします。

4.17.define

define 名前 原子表現

任意の原子グループに固有の名前をつけます。

4.18.display

display all

全てのファイルの画像を表示します。

display none

全てのファイルの画像を非表示にします。

display -a/-r ファイルID

指定したファイルの画像だけを表示し、その他のファイルの画像は非表示にします。 コンマで区切って複数のファイルを指定することもできます。 -a オプションをつけると、指定したファイルの画像の状態を表示状態に変更し、その他のファイルの状態は変更しません。 -r オプションをつけると、指定したファイルの画像の状態を非表示状態に変更し、その他のファイルの状態は変更しません。

4.19.displayatom

displayatom on/true

選択した原子を表示します。

displayatom off/false

選択した原子を表示しないようにします。

4.20.displayvertex

displayvertex on/true

選択した頂点を表示します。

displayvertex off/false

選択した頂点を表示しないようにします。

4.21.echo

echo 文字列

指定した文字列をメッセージ領域に表示します。

  • 例005:指定文字列を出力

4.22.exit

exit

アプリケーションを終了します。このコマンドはアプレット版では使えません。

4.23.fit

fit file1_ID file2_ID

file1の画像をfile2の画像と重なるよう移動します。

4.24.fselect

fselect all

全てのファイルを選択します。

fselect none

全てのファイルを選択解除します。

fselect -a/-r ファイルID

指定したファイルのみを選択し、その他のファイルは選択解除します。 コンマで区切って複数のファイルIDを指定することもできます。 -a オプションをつけると、指定したファイルの状態を選択状態に変更し、他のファイルの状態は変更しません。 -r オプションをつけると、指定したファイルの状態を選択解除状態に変更し、他のファイルの状態は変更しません。

4.25.hbond

hbond

hbonds コマンドと同じ働きをします。

4.26.hbonds

hbonds on/true

選択範囲内にある水素結合を点線で表示します。

hbonds off/false

選択範囲内の水素結合の表示を消します。

hbonds 半径

選択した水素結合を指定した半径の線で表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大2.0(Å)または500(ラスモル単位)です。

4.27.help

help コマンド

コマンドの使用方法に関する説明を表示します(英語版記載の内容)。

4.28.load

読み込んで表示するファイルを指定します。ローカルファイルの場合は、絶対パスまたはjVのjarファイルがあるディレクトリからの相対パスで指定します(UNIX系OSでホームディレクトリを示す"~" は使えないようです)。URLを使ってリモートファイルを開くこともできます。fit ファイルID を指定すると既に開かれている指定IDの画像と重なる位置にファイルが読み込まれます。読み込む際、変換行列を指定することもできます。このコマンドはアプレット版では使えません。

load pdbml ファイル名 fit ファイルID biomolecule assembly ID filter 原子表現

PDBMLファイルを開きます。all-atomファイル(atom_siteCategoryも含め全情報を収めたPDBML)、no-atomファイル(atom_siteCategoryを除いたPDBML)、ext-atomファイル(各atom_site要素の内容を1要素にまとめた形式のPDBML)およびPDBMLplusいずれも利用できます。但し、no-atomファイルを指定して分子を表示させるには、no-atomファイルと同一フォルダにext-atomファイルも置いておく必要があります(no-atomファイルには原子座標情報がなく、ext-atomファイルを読んで情報を補完するため)。これがないと「Can't Find PDBML Ext-File.」エラーとなります。またext-atomファイルを指定した場合、二次構造はjVが算出した上で表示します(ext-atomファイルにはstruct_confCategory、struct_sheet_rangeCategoryなど二次構造に関する情報が含まれないため)。そのため、ext-atomを読み込んだ場合と、それ以外のPDBML(plus)ファイルを読み込んだ場合では二次構造の表示が異なる場合があります。

アプレット<param name="pdbmlURL" value="PDBMLファイル"/> の指定に相当します。

biomolecule assembly IDで生物学的単位を表示するよう指定することができます。個々の変換に対し一意なmodel IDを割り振って構造を読み込みます。対象鎖と適用する変換についてはshow informationコマンドで確認することができます。

filterオプションを指定した場合、指定した原子表現に適合する原子だけが読み込まれます。原子表現には一部の表現(bonded、helix、sheet、turn、within、pdbj:)を除き、任意の表現を使うことができます。なお原子表現に空白を含む場合、ダブルクォートまたは括弧で囲む必要があります。

load mmcif ファイル名 fit ファイルID biomolecule assembly ID filter 原子表現

mmCIFファイルを開きます。ファイルの種類が異なる点を除けばPDBMLと同じです。

アプレット<param name="mmcifURL" value="mmCIFファイル"/> の指定に相当します。

load pdb ファイル名 fit ファイルID biomolecule assembly ID filter 原子表現

PDBファイルを開きます。ファイルの種類が異なる点を除けばPDBMLと同じです。

アプレット<param name="pdbURL" value="PDBファイル"/> の指定に相当します。

load polygon ファイル名 fit ファイルID

ポリゴンファイルを開きます。

アプレット<param name="polygonURL" value="ポリゴンファイル"/> の指定に相当します。

load polygon_cgo ファイル名 fit ファイルID

eF-siteシステムで配布されているポリゴンCGOファイルを開きます。

load animation ファイル名 fit ファイルID filter 原子表現

アニメーションファイルを開きます。

load ftp PDB ID fit ファイルID biomolecule assembly ID filter 原子表現

PDBMLファイルをPDBj FTPサイトから検索して開きます。

  • 例007:ファイルのロード
load efsite eFsite ID

PDBファイルとefvetファイルをeF-siteデータベースから検索して開きます。

4.29.pause

pause

スクリプトファイルの実行を停止します。 任意のキーを押すと実行を再開します。

4.30.pdbj_describe

pdbj_describe ファイルID 名前

ファイルIDおよび名前で指定したPDBMLplusにおけるjVコマンドについてのドキュメントを表示します。名前を指定しなかった場合は利用可能な全ての名前が列挙されます。

4.31.pdbj_execute

pdbj_execute ファイルID 名前

ファイルIDおよび名前で指定したPDBMLplusにおけるjVコマンドを実行します。

4.32.quit

quit

exitコマンドと同じ働きをします。このコマンドはアプレット版では使えません。

4.33.refresh

refresh

全ての画像を描き直します。

4.34.reset

4.34.1.default

reset

全ての画像の初期の位置(回転の中心)、向きに戻します。

4.34.2.cartoon

reset cartoon

Cartoon表現におけるリボンの太さを初期状態に戻します。

4.34.3.line_width

reset line_width

ポリゴン画像における線の太さを初期状態に戻します。

4.34.4.pickradius

reset pickradius

各原子のマウス選択可能な領域を初期状態に戻します。

4.34.5.point_size

reset point_size

ポリゴン画像における点の大きさを初期状態に戻します。

4.34.6.polyline_width

reset polyline_width

ポリゴン画像の線の太さを初期状態に戻します。

4.34.7.transparency

reset transparency

ポリゴン画像の透明度を初期状態に戻します。

reset point_transparency

ポリゴン画像における点の透明度を初期状態に戻します。

reset line_transparency

ポリゴン画像における線の透明度を初期状態に戻します。

reset triangle_transparency

ポリゴン画像における三角形の透明度を初期状態に戻します。

reset quad_transparency

ポリゴン画像における四角形の透明度を初期状態に戻します。

reset polyline_transparency

ポリゴン画像における複合線の透明度を初期状態に戻します。

4.35.ribbons

ribbons on/true

選択した残基をリボン表面形式で表示します。管モデル(tube)で表示するのに十分な原子がない鎖については代わりに主鎖表現(backbone)で表示します。

ribbons off/false

選択した残基のうちリボン表面形式で表示されたものを消去します。

ribbons 半幅長

選択した残基を指定した幅が半分となる太さを持つリボン表面形式で表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大4.0(Å)または1000(ラスモル単位)です。

4.36.rotate

rotate x/y/z 角度

指定した軸方向を回転軸として、指定した角度だけ図を回転します。

4.37.save

座標情報、スクリプト、画像を保存します。保存場所は絶対パスまたはjVのjarファイルがあるディレクトリからの相対パスで指定します。このコマンドはアプレット版では使えません。但し署名済みアプレットであれば、右クリックメニューの[File]-[Save]の[PNG]または[JPEG]をクリックして画像を保存できます。

save pdb ファイル名

PDBフォーマット形式で、現在選択されている原子の情報を保存します。

save mmcif ファイル名

mmCIF形式で、現在選択されている原子の情報を保存します。

save script ファイル名

現在表示している画像のスクリプトファイルを作成します。 これにはコマンド操作、メニュー操作、マウス操作が全て記録されます。

save png ファイル名

現在表示している画像のPNG画像ファイルを作成します。

save jpeg ファイル名 圧縮率

現在表示している画像のJPEG画像ファイルを作成します。圧縮の程度を 0 より大きくかつ 1 以下である値(0 < 圧縮率 ≤ 1)で指定します。1は圧縮なしを意味します。指定がない場合の既定値は 0.75 です。

4.38.script

script ファイル名

指定したスクリプトファイルを開いて実行します。リモートファイルの指定にはURLが使用できます。このコマンドはアプレット版では使えません。

4.39.select

select

全ての原子を選択します。ヘテロ原子と水素が選択されるかどうかはheteroとhydrogenの内部パラメータの設定に依存します。

select all

へテロ原子と水素も含めた全ての原子を選択します。

select none

全ての選択を解除します。

select 原子表現

原子表現で指定されたグループを選択します。

4.40.selectvertex

selectvertex all

全ての頂点を選択します。

selectvertex none

全ての頂点を選択解除します。

selectvertex 頂点表現

頂点表現で指定された頂点グループを選択します。

4.40set

4.41.1ambient

set ambient 光量値

環境光の量を設定します。設定できる値は0から100までの間です。 値を指定しなかった場合、初期値の33に設定が戻ります。 設定は次回起動時には初期値の33に戻ります。

4.41.2adjustview

set adjustview on

新しいファイルを読み込んだ時、視点を自動的に調整します。

set adjustview off

新しいファイルを読み込んだ時、視点を調整せずそのままにします。

4.41.3background

set background

背景色を変更します。 色はRGB [r,g,b]値、または既定の色名で指定します。 初期値は黒(0,0,0)で、次回起動時にはこの初期値に戻ります。

4.41.4bondmode

set bondmode and

個々の結合をどのように選択するかを指定します。 結合された原子両方が選択された時、結合が選択されます。

set bondmode or

個々の結合をどのように選択するかを指定します。 結合された原子のどちらか一方が選択された時に結合を選択します。

4.41.5cartoon

set cartoon 半幅長

太いリボン表現(cartoon表現)時のリボンの太さを指定します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大2.0(Å)または500(ラスモル単位)です。 パラメータを指定しなかった場合、指定は初期値(0.2Å)に戻ります。 また、次回起動時にも設定は初期値に戻ります。

4.41.6cartoon_loop_tube

このコマンドは太いリボン(cartoon)表現における環状領域の表現方法を設定します。 この設定はjV終了時に保存され、次回起動時にも引き継がれます。

set cartoon_loop_tube on

太いリボン表現において、環状領域を管で描きます。

set cartoon_loop_tube off

太いリボン表現において、環状領域を角柱で描きます。 初期状態ではこの設定です。

4.41.7cartoon_round

このコマンドは太いリボン(cartoon)表現におけるリボンの縁の表現方法を設定します。 この設定はjV終了時に保存され、次回起動時にも引き継がれます。

set cartoon_round on

太いリボン表現において、リボンの縁を丸く描きます(β鎖を除く)。

set cartoon_round off

太いリボン表現において、リボンの縁を丸くせずに描きます。 初期状態ではこの設定です。

4.41.8center

set center 原子表現

選択したファイルの既定の中心位置を、選択した原子の中心に設定します。

set center [x,y,z]

選択したファイルの既定の中心位置を、指定した座標位置に設定します。

4.41.9diffuse1

set diffuse1 光量値

第1散乱光の量を指定します。 指定可能な値は0から100までの間で、 値を指定しなかった場合、初期値の50に設定されます。

4.41.10   diffuse1_direction

set diffuse1_direction [x,y,z]

第1散乱光の方向を指定します。 値を指定しなかった場合、初期値の[-1, -1, -1]に設定されます。

4.41.11diffuse2

set diffuse2 光量値

第2散乱光の量を指定します。 指定可能な値は0から100までの間で、 値を指定しなかった場合、初期値の50に設定されます。

4.41.12   diffuse2_direction

set diffuse2_direction [x,y,z]

第2散乱光の方向を指定します。 値を指定しなかった場合、初期値の[-1, -1, -1]に設定されます。

4.41.13drawlevel

set drawlevel 線分数

球と円柱の透視図に関する精度を指定します。 値は5以上の整数で指定し、この値は半円を表す線分の数を表します。

4.41.14   efsite_url

set efsite_url URL

eF-siteのURLを設定します。

4.41.15   ext_site_url

set ext_site_url prefix URL

外部データベースサイトのURLを設定します。

4.41.16hbond

set hbond

働きはset hbonds コマンドと同じです。

4.41.17hbonds

set hbonds backbone

主鎖結合(バックボーン)間の水素結合を表示します。

set hbonds sidechain

側鎖間の水素結合を表示します。

4.41.18hetero

set hetero on

selectコマンドの選択対象の既定値に、リガンドなどメインの分子以外も含めるよう設定します。

set hetero off

selectコマンドの選択対象の既定値に、リガンドなどメインの分子以外は含めないよう設定します。

4.41.19hydrogen

set hydrogen on

selectコマンドの選択対象の既定値に、水素原子を含むよう設定します。

set hydrogen off

selectコマンドの選択対象の既定値に、水素原子を含まないよう設定します。

4.41.20imagesize

set imagesize 高さ

3次元表示パネルの大きさをピクセル単位で指定します。 大きさは画面サイズ以内で、幅は偶数のピクセル数で設定されます。

4.41.21   line_width

set line_width 線幅

ポリゴン画像の線幅を設定します。 値は正の数で指定して下さい。

4.41.22loadcenter

set loadcenter on

ファイルを開く時、既に開いている全画像の中央を初期中心位置として新しいファイルを読み込むよう設定します。メニューの [Options]-[Load To Center] と同じ動作です。

set loadcenter off

ファイルを開く時、個々のファイルの座標設定を中心位置の既定値に設定します。

4.41.23   pdbml_noatom_url

set pdbml_noatom_url URL

PDBML noatom ファイルのURLを設定します。

4.41.24   pdbml_extatom_url

set pdbml_extatom_url URL

PDBML extatom ファイルのURLを設定します。

4.41.25   pdbml_plus

set pdbml_plus URL

PDBML plus ファイルのURL(ファイル名を除いたベース部分)をURLで指定した値に設定します。既定値はftp://ftp.pdbj.org/XML/pdbmlplus/pdbml_xp_gz/です。appletの場合、ftp.pdbj.orgがウェブページとが異なるドメインになっているためアクセスが拒否されるという問題が発生する場合があります(クロスドメイン制約)。この場合、ウェブページと同じドメインにPDBMLplusファイルを配置し、このコマンドでPDBMLplusのベースURLを変更することでPDBMLplusファイルにアクセスできるようになります。なお、PDBMLplusファイルのファイル名書式はPDBID-pdbmlplus.xmlまたはPDBID-pdbmlplus.xml.gzです(ファイル名の書式は指定変更できません)。

  • 例:PDBMLplusのベースURLを「http://pdbj.org/XML/pdbmlplus/pdbml_xp_gz/」に設定
    set pdbml_plus http://pdbj.org/XML/pdbmlplus/pdbml_xp_gz/
    

4.41.26picking

メニューバーの [Options]-[Pick Off/Ident/Coordinate/Distance/Center/Select] と同じ動作です。

set picking off

画面中の原子をクリックしても何もしません。

set picking ident

画面中の原子をクリックすると、その原子の固有情報を表示するように設定します(既定値)。

set picking coord

画面中の原子をクリックすると、選択した原子の座標を固有情報とともに表示するように設定します。

set picking distance

画面中の原子をクリックすると、続いてクリックした原子との距離を表示するように設定します。

set picking center

画面中の原子をクリックすると、回転の中心と表示の中央の設定をクリックした原子に置くように設定します。

set picking select

画面中の原子をクリックすると、クリックした原子を含むファイルを選択するよう設定します。

  • 例012:マウスピッキングの設定

4.41.27pickradius

set pickradius 領域半径

マウスクリックによる原子指定(ピッキング)において、反応する領域の大きさを、原子の中心からの半径をÅまたはラスモル単位(=0.004Å)で指定します。 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値に上限はなさそうです(100万Åでも設定できました)。 初期値は不明、値は省略不可です。

4.41.28   point_size

set point_size 点直径

ポリゴン画像における点の大きさを設定します。 点直径には正の値を設定します。 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値に上限はなさそうです(100万Åでも設定できました)。

4.41.29   polyline_width

set polyline_width 線幅

ポリゴン画像における線の太さを設定します。 線幅には正の値を設定します。 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値に上限はなさそうです(100万Åでも設定できました)。

4.41.30projection

set projection perspective

投影モードを透視投影(1点に光源を置いて立体を平面に投影する投射方法)に設定します。 目で見た見え方に近く、この設定が初期値です。

set projection parallel 画像サイズ

投影モードを平行投影(平行な光線を当てて立体を平面に投影する投影方法)に設定します。 画像の大きさ(画面に一致させる高さ)を指定することもできます。 小数値を指定するとÅ、整数値を指定するとラスモル単位(=0.004Å)として扱われます。

4.41.31ribbonback

set ribbonback

リボンモデルの背景色を設定します。 色はRGB値[r,g,b]、または既定の色名(色表現参照)で指定します。

set ribbonback none

リボンモデルの背景色を初期値に戻します。

4.41.32specular

set specular on/true

個体物質の反射強調の表示を行います。

set specular off/false

個体物質の反射強調の表示を行いません。

set specular 反射度

固体物質の反射強調の表示を行います。 値は0から100までの間で明るさを指定し、0を指定すると最も暗く、100を指定すると最も明るくなります。初期値は50.0です。

4.41.33specpower

set specpower 光沢度

固体物質の光沢に関する設定を行います。 値は0から100までの間で指定し、0を指定すると表面を散乱状態にし、100を指定すると光沢のある表面にします。初期値は0です。

4.41.34ssbond

set ssbond

働きはset ssbonds コマンドと同じです。

4.41.35ssbonds

set ssbonds backbone

主鎖結合間のジスルフィド結合を表示します。

set ssbonds sidechain

側鎖間のジスルフィド結合を表示します。

4.41.36stereo

set stereo

働きはstereo コマンドと同じです。

4.41.37transparency

set transparency 透明度

ポリゴン画像の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

set point_transparency 透明度

ポリゴン画像における点の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

set line_transparency 透明度

ポリゴン画像における線の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

set triangle_transparency 透明度

ポリゴン画像における三角形の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

set quad_transparency 透明度

ポリゴン画像における四角形の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

set polyline_transparency 透明度

ポリゴン画像における多線の透明度を設定します。 指定できる値は0から1までで、値が大きい程透明になります。 初期値は0です。

4.41.38viewpoint

set viewpoint {x,y,z}

指定した座標に視点を設定します。

4.42.show

show efsite_url

eF-site のURLを表示します。

show ext_site_url

外部データベースサイトのURLを表示します。

show godata

分子の遺伝オントロジー(GO)データを表示します。

show imagesize

3次元レンダリングパネルの大きさを表示します。

show information

分子の詳細情報を表示します。

show pdbml_url

PDBMLファイルのURLを表示します。

show site prefix:db:category

外部データベース情報を表示します。

show transform

現在表示している分子の位置、回転状況の情報を表示します。

show viewpoint

現在の視点情報を表示します。

show pdbj

PDBj表現で利用できるキーワードを表示します。

4.43.slab

slab on/true

画像をz軸(奥行き方向)に垂直な平面で切断する機能(zクリッピングプレーン機能)をONにします。ON/OFFはメニューの [Options]-[Slab] でも行えます。

slab off/false

画像をz軸(奥行き方向)に垂直な平面で切断する機能(zクリッピングプレーン機能)をOFFにします。

slab 切断割合

画像切断位置を相対値で設定します。 パラメータは0から100の間で設定できます。 0を指定すると完全に見えなくなり、100を指定すると完全に見えるようになります。

slab -v Z座標

画像切断位置を絶対値で設定します。 指定はZ座標(奥行き方向)を指定して行います。

4.44.spacefill

メニューの[Display][Spacefill]による操作とこのコマンドによる操作は似ていますが、メニューでは選択範囲の表示が空間充填表現に「変更される」のに対し、このコマンドでは既存の表示を残したまま空間充填表現が「追記される」点が異なります。既存の表示がワイヤーフレームなどの場合は追記された球に隠れて元の表示が見えなくなりますが、太いリボン表現(cartoon)などの場合にはリボンから球が生えて追記されたことが分かります。

spacefill on/true

選択されている原子の表示方法を球表示(空間重点表現)に変更します。

spacefill off/false

選択されている原子の中で表示方法が球表示(空間重点表現)に指定されている部分の表示を消します。

spacefill 半径

選択原子中、表示方法が球表示(空間重点表現)に指定されている部分を指定した半径で表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。指定できる値は最大2.0(Å)または500(ラスモル単位)です。半径を指定しない場合の既定値は以下の通りです。

  • 炭素(C)→1.88
  • 窒素(N)→1.5
  • 酸素(O)→1.4
spacefill temperature

選択原子中、表示方法が球表示(空間重点表現)に指定されている部分を、温度因子値を半径に使って表示します。

4.45.ssbond

ssbond

ssbonds コマンドと同じ働きをします。

4.46.ssbonds

ssbonds on/true

選択したジスルフィド結合を表示します。

ssbonds off/false

選択したジスルフィド結合の表示を非表示にします。

ssbonds 半径

選択したジスルフィド結合を指定した半径で表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大2.0(Å)または500(ラスモル単位)です。

4.47.stereo

stereo 角度

表示を指定した分離角の2分割ステレオ画像に変更します。正の値を指定すると指定した分離角(片側の回転角度で単位は度(°)、視差角としては左右で2倍の角度)の平行法、負の値を指定するとその絶対値を分離角とした交差法での表示となります。引数指定がない場合の既定値は3(左右3°ずつ、合計6°の視差角での平行法表示)です。

stereo redblue/redcyan/redgreen 角度

表示を色分け(アナグリフ)立体視表示に変更します。第1引数に指定できる値はredblueredcyanredgreenのいずれか一つで、それぞれ「赤青」「赤シアン」「赤緑」の色分け立体視表示となります。 第2引数の意味は前項と同じです。

stereo on/true/redblue/redcyan/redgreen

第1引数にonまたはtrueを指定すると2分割ステレオ表示に、redblueredcyanredgreenのいずれか一つを指定すると、それぞれ「赤青」「赤シアン」「赤緑」の色分け立体視表示となります。視差角には最後に設定した内容が適用されます。jV起動後一度も視差角の設定を変更していない場合は、初期値である3(左右3°ずつ、合計6°の視差角での平行法表示)が視差角の設定として用いられます。

引数を指定しなかった場合は、実行する度に、平行法2分割→交差法2分割→赤青色分け→赤シアン色分け→赤緑色分け→ステレオOFFの順でステレオ表示設定が切り替わります。

stereo off/false

ステレオ表示をOFFにします。

4.48.structure

structure

Kabsch と Sander の DSSP アルゴリズムを用いて予測された二次構造(らせん、シートなど)の個数を表示し、二次構造予測を行います。

4.49.trace

trace on/true

選択した残基を太さは 75 ラスモル単位(0.3Å)の管モデル(tube model、主鎖を滑らかな管で表現したモデル)で表示します。管モデルで表示するのに十分な原子がない鎖については代わりに主鎖表現(backbone)で表示します。

trace off/false

選択した残基中の管表現を消します。

trace 半径

選択した残基のうち管表現されている部分を指定した半径で表示します。 指定値の単位はÅまたはラスモル単位(=0.004Å)で、 小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。 指定できる値は最大2.0(Å)または500(ラスモル単位)です。

4.50.translate

translate x/y/z 移動距離

画像を指定した軸に沿って、指定した長さ(Å単位)移動します。

4.51.wireframe

メニューの[Display][Wireframe]による操作とこのコマンドによる操作は似ていますが、メニューでは選択範囲の表示がワイヤーフレームに「変更される」のに対し、このコマンドでは既存の表示を残したままワイヤーフレームが「追記される」点が異なります。既存の表示が空間充填表現(spacefill)などの場合はワイヤーフレームを追記しても隠れて見えず何も変わっていないように見えますが、太いリボン表現(cartoon)などの場合にはワイヤーフレームの枝が生えて追記されたことが分かります。

wireframe on/true

選択範囲内の結合をワイヤーフレームで表示します。表示線の太さの半径は既定値の0.004Å(1ラスモル単位)です。wireframe 1と太さは同じですが、遠近に関係なく実線で表示されます。

wireframe off/false

選択範囲内で表示指定がワイヤーフレーム表現になっている部分の表示を消します。

wireframe 半径

選択範囲内で表示指定がワイヤーフレーム表現になっている部分を、指定した半径の太さの線で表示します。半径の指定はÅまたはラスモル単位(=0.004Å)で行います。小数値を指定するとÅ、整数値を指定するとラスモル単位の値とみなされます。指定できる値は最大2.0(Å)または500(ラスモル単位)です。

なお、棒(stick)表現( [Display][Sticks] )は wireframe 0.2 で、色をCPK( [Colors][CPK] )に設定したものになります。

  • 例016:ワイヤーフレーム表示操作

4.52.write

write

save コマンドと同じ働きをします。このコマンドはアプレット版では使えません。但し署名済みアプレットであれば、右クリックメニューの[File]-[Save]の[PNG]または[JPEG]をクリックして画像を保存できます。

4.53.zap

zap ファイルID

指定したファイルと閉じます。 コンマで区切って複数のファイルIDを指定することができます。 パラメータを指定しなかった場合は、全てのファイルを閉じます。

4.54.zoom

zoom 拡大率

画像全体の拡大率を指定します。 値は現在の大きさに対するパーセンテージで指定します。 値の最小値は10.0です。

スタンドアロン版でしか使えないコマンド

以下のコマンドはスタンドアロン版でのみご利用になれます。アプレット版では利用することができず、これらのコマンドを実行しようとすると「Command Not Supported.」エラーが表示されます。但しバージョン3.8以降で、署名済みアプレットを用いていれば、右クリックメニューの[File]-[Save]の[PNG]または[JPEG]をクリックして画像を保存できます(save、writeコマンドでは保存できません)。


3. 基本的な使い方 トップページに戻る 5. コマンドリスト(カテゴリ別)

Valid XHTML 1.1