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本日の話題

３つの分子ビューアの基本的な使い方

PyMOL

UCSF Chimera

Molmil

PDBデータのなりたち

どんな情報が収納されているのか？

どういうファイルフォーマットで書かれているのか？



Protein Data Bank (PDB)
・生体高分子の立体構造のデータベース

・現在のデータ数 (2021/09/22): 1,82,418件

X線結晶解析 NMR 電子顕微鏡 その他 合計

159849(87.6 %) 13487(7.4%) 8548 (4.7%) 534 (0.3%) 182418

A鎖

B鎖

C鎖

D鎖

HEM (asym_id: E)

HEM (asym_id: F)

HEM (asym_id: G)

HEM (asym_id: H)

PDB_ID:2hhb
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(taken from PDBj 2021/09/22)

・各エントリには４文字の英数字のPDB_IDを持つ(2hhb, 1a5kなど)

・各高分子には、鎖識別子(A,B,C,D…)が付く

・低分子化合物には化合物ID（残基名）
(ALA, HEM, ATP,…)が付く

・各残基には残基番号がつく(1, 2, 3, 4,…)

・各原子には固有の原子名(Cα:CA, Cβ:CB, 
Cγ:CGなど)が付加

・各分子ごとにasym_idが付く



PDBで使われている原子名の例。重原子のみ示した。CYSはシステイン、GLUはグルタミン
酸、DAは、DNAの構成要素となる2’-deoxyadenosine-5’-monophosphate.
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残基名と原子名

※Chemical Components Dictionaryというデータベースで管理

※PDBjのWEBサイトで、残基名で検索すると、これらの原子名の命名法を見ることができます

※mmCIFでは、残基名はlabel_comp_idという名前、原子名はlabel_atom_idと呼ばれる

※残基名は、これまでは３文字以下。しかし、今後、拡張される予定



立体構造データのフォーマット
•旧PDBフォーマット
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• mmCIFフォーマット

・PDB創立のころ(1971年)から使われていたフォーマット

・１行１原子。１行８０文字の固定長のフォーマット。

・原子番号は５文字なので、99999個を超える原子は扱えない。

・鎖識別子は１文字なので、62鎖を超えると扱えない。

・STARフォーマットの一種。可変長。

・キー・バリュー形式と表形式を併用

・値の長さは可変なので、鎖や原子数の上限はない。

・2014年から、PDBの正規なフォーマットとなる

・座標以外のデータの記述は場当たり的

・座標以外の様々なデータも、柔軟に記述できる

・2019年7月から、 X線のデータ登録にmmCIFが必須となる

・主要な分子表示、モデリング、構造決定のソフトウエアは対応済み

PDB

mmCIF



HEADER    OXYGEN TRANSPORT                        07-MAR-84   2HHB              

TITLE     THE CRYSTAL STRUCTURE OF HUMAN DEOXYHAEMOGLOBIN AT 1.74 ANGSTROMS     

ATOM      1  N   VAL A   1       6.130  16.559   4.905  1.00 41.29           N  

ATOM      2  CA  VAL A   1       6.870  17.784   4.702  1.00 41.33           C  

ATOM      3  C   VAL A   1       8.377  17.548   4.913  1.00 31.64           C  

ATOM      4  O   VAL A   1       8.820  16.980   5.922  1.00 38.31           O  

ATOM      5  CB  VAL A   1       6.345  18.763   5.731  1.00 52.26           C  

ATOM      6  CG1 VAL A   1       6.745  20.188   5.356  1.00 52.75           C  

ATOM      7  CG2 VAL A   1       4.826  18.612   5.847  1.00 58.75           C  

ATOM      8  N   LEU A   2       9.146  18.005   3.962  1.00 27.63           N  

ATOM      9  CA  LEU A   2      10.599  17.914   4.153  1.00 33.62           C  

ATOM     10  C   LEU A   2      11.062  19.085   5.062  1.00 32.51           C  

ATOM     11  O   LEU A   2      10.829  20.254   4.744  1.00 31.03           O  

ATOM     12  CB  LEU A   2      11.269  18.078   2.776  1.00 34.38           C  

ATOM     13  CG  LEU A   2      10.986  16.983   1.769  1.00 32.23           C  

ATOM     14  CD1 LEU A   2      11.735  17.168   0.427  1.00 36.30           C  

ATOM     15  CD2 LEU A   2      11.276  15.630   2.404  1.00 38.42           C  

ATOM     16  N   SER A   3      11.674  18.766   6.158  1.00 26.50           N  

ATOM     17  CA  SER A   3      12.286  19.774   7.034  1.00 27.60           C  

ATOM     18  C   SER A   3      13.529  20.322   6.334  1.00 30.36           C  

ATOM     19  O   SER A   3      13.995  19.754   5.344  1.00 27.40           O  

ATOM     20  CB  SER A   3      12.719  19.060   8.326  1.00 23.83           C  

ATOM     21  OG  SER A   3      13.844  18.245   8.107  1.00 29.07           O  

:

HETATM 4389  CHA HEM A 142       8.634   7.898 -18.334  1.00 17.24           C  

HETATM 4390  CHB HEM A 142      10.386   9.965 -14.276  1.00 23.17           C  

HETATM 4391  CHC HEM A 142       8.337   6.403 -11.611  1.00 11.04           C  

: 原子名原子番号 残基名 残基番号
鎖識別子

X座標 Y座標 Z座標 温度因子占有率 元素名

旧PDBフォーマットの立体構造データの例
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A鎖

B鎖

C鎖

D鎖

HEM

HEM

HEM

PDB_ID:
2hhb

HEM

80文字の固定長

パンチカード時代の名残り

PDB



data_2HHB

# 

_entry.id   2HHB 

# 

_struct.title 'THE CRYSTAL STRUCTURE OF HUMAN DEOXYHAEMOGLOBIN AT 1.74 ANGSTROMS RESOLUTION'

_struct.pdbx_descriptor 'HEMOGLOBIN (DEOXY)' 

#

loop_

_atom_site.group_PDB

_atom_site.id 

_atom_site.type_symbol

_atom_site.label_atom_id

_atom_site.label_alt_id

_atom_site.label_comp_id

_atom_site.label_asym_id

_atom_site.label_entity_id

_atom_site.label_seq_id

_atom_site.pdbx_PDB_ins_code

_atom_site.Cartn_x

_atom_site.Cartn_y

_atom_site.Cartn_z

_atom_site.occupancy

_atom_site.B_iso_or_equiv

_atom_site.pdbx_formal_charge

_atom_site.auth_seq_id

_atom_site.auth_comp_id

_atom_site.auth_asym_id

_atom_site.auth_atom_id

_atom_site.pdbx_PDB_model_num

ATOM   1    N  N   . VAL A 1 1   ? 6.130   16.559  4.905   1.00 41.29 ? 1   VAL A N   1 

ATOM   2    C  CA  . VAL A 1 1   ? 6.870   17.784  4.702   1.00 41.33 ? 1   VAL A CA  1 

ATOM   3    C  C   . VAL A 1 1   ? 8.377   17.548  4.913   1.00 31.64 ? 1   VAL A C   1 

ATOM   4    O  O   . VAL A 1 1   ? 8.820   16.980  5.922   1.00 38.31 ? 1   VAL A O   1 

ATOM   5    C  CB  . VAL A 1 1   ? 6.345   18.763  5.731   1.00 52.26 ? 1   VAL A CB  1 

ATOM   6    C  CG1 . VAL A 1 1   ? 6.745   20.188  5.356   1.00 52.75 ? 1   VAL A CG1 1 

ATOM   7    C  CG2 . VAL A 1 1   ? 4.826   18.612  5.847   1.00 58.75 ? 1   VAL A CG2 1 

ATOM   8    N  N   . LEU A 1 2   ? 9.146   18.005  3.962   1.00 27.63 ? 2   LEU A N   1 

ATOM   9    C  CA  . LEU A 1 2   ? 10.599  17.914  4.153   1.00 33.62 ? 2   LEU A CA  1  

:

HETATM 4385 C  CHA . HEM E 3 .   ? 8.634   7.898   -18.334 1.00 17.24 ? 142 HEM A CHA 1 

HETATM 4386 C  CHB . HEM E 3 .   ? 10.386  9.965   -14.276 1.00 23.17 ? 142 HEM A CHB 1 A CHC 1 

:

#

原子座標

登録者が入力する(auth_のアイテム)

データベース管理者が入力(label_のアイテム)

原子名原子番号 残基名 残基番号
asym_id(鎖識別子)

X座標 Y座標 Z座標 温度因子占有率
元素名 残基名

asym_id(鎖識別子)
原子名

残基番号

表形式

キー・バリュー形式

mmCIFフォーマットの立体構造データの例
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A鎖

B鎖

C鎖

D鎖
HEM

asym_id: E

HEM

asym_id: F

HEM

asym_id: G

HEM

asym_id: H

PDB_ID
2hhb

項目は[カテゴリ名].[アイテム名]

entity_id

※2hhbの場合58個のカテゴリがある

mmCIF



mmCIFファイルの特長
• STARフォーマット。キーバリュー形式と表形式の併用で、人
間にも比較的読みやすい。

• [カテゴリ名].[アイテム名]で整理された項目名

• カテゴリatom_site以外に、50-80ほどのカテゴリ（表）

• 鎖識別子、原子番号などの文字数は無制限

• 残基番号、鎖識別子については、読みやすさと統一性を両
立するため、著者入力とデータベース管理者入力の２種が
書かれる。

• Biological unitなど、非対称単位以外の複合体(assembly)
の生成法が正確に記載されている。

A鎖

B鎖

C鎖

D鎖
HEM
asym_id: E

HEM
asym_id: F

HEM
asym_id: G

HEM
asym_id: HPDB_ID:2hhb PDBcode:1a5k

Asymmetric Unit assembly 1
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Relionの出力ファイルもSTAR
フォーマットです！



mmCIFを使わなければならない場合
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１．巨大構造を扱う場合は、mmCIFを読み込むべき

２．立体構造を扱うプログラムの開発者は、入力をmmCIFに対
応するよう改良すべき。（出力は任意）

３．PDBデータベース全体に対して、統計的・包括的な
解析を行う場合は、mmCIFをベースにすべき

巨大な構造の場合、mmCIF形式のみで公開されています。

計算結果の出力は、旧PDBフォーマットでもかまいません。

mmCIFのデータベース管理者による残基番号、鎖識別子は、
統一的な基準で決まっているので、PDBデータベース全体の統計を
とる場合に向いています。

鎖識別子が２文字以上の場合、巨大でなくてもmmCIFだけの構造はあります



PDB形式変換不可エントリ :mmCIFだけで公開されているエントリ
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PDB形式変換不可エントリー

2021年9月22日時点で
2259エントリ

鎖識別子(auth_asym_id)を２文字以上使うと、原子数が小さくてもmmCIFだけの公開となり、
「PDB形式変換不可エントリー」とみなされる。



なんとなく構造を眺めるだけなら…

• PDBのウェブページをクリックして、３D構造を眺めるだけ
なら、ファイルフォーマットを意識する必要はありません

• PyMOL、UCSF Chimeraなど最近のビューワは、直接PDB
サーバから構造を読みにいく機能(“fetch”)があるので、
ファイルフォーマットを意識する必要はありません

• ただし、残基名、残基番号、鎖識別子などの事情はある
程度理解しておいたほうがいいかもしれません
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PDB IDの探し方

(2)PDBjのキーワード検索

(1)文献検索
GoogleやPubMedなどで、関心があるタンパク質・ファミリー名といっしょに、
3D structure, X-ray, NMR, Cryo-EMなどのキーワードとともに文献を検索

構造を決定した論文には必ずPDB IDが書いてある

(3)PDBjのアミノ酸配列検索

PDBjのトップ画面の上のフォームに
タンパク質名、ファミリー名などを入力 詳細検索(PDBjのRDBを直接検索する)も可能

関心のあるタンパク質のアミノ酸配列から
配列相同性検索で類似した蛋白質の
立体構造を検索

配列が類似した蛋白質は構造も類似
しているので、ホモロジーモデリング
の鋳型としても使える



HOMCOSを利用した配列からのPDB IDの検索

(1)「タンパク質に対する結合分子の検索」を選ぶ

https://homcos.pdbj.org

(2) UniProtIDかアミノ酸配列を入力

単量体

ヘテロ複合体

核酸との複合体

化合物との複合体

(3)  類似蛋白質の立体構造が
複合体の種類別に表示される



PyMOL
・Warren Lyford  Delano (1972-2009) によって2000年ごろから開発され
た分子描画ソフト。2003年からDelano Scientific社によって配布・販売。

・2009年にDelano氏が死去。その後は、Schrödinger社で維持・配布

・PyMOLは、商品(commercial product)だが、そのソースコードは無料

で公開。つまり、ソースコードをダウンロードして、自分でコンパイル
して使うのは無償。

・Webページから試用版(ライセンス無し版)の実行バイナリのダウン
ロードは可能(Windows, macOS, Linux) ただし、試用版では、画面
に”No License File – For Evaluation Only”のメッセージが常に画面に
表示される。

・正式版ライセンスは有料。Academic １人/１年で$99。他にもいろい
ろなプラン。

・教育用無料ライセンスでは”Education-use-only”のメッセージが常に
画面に表示される。



PyMOL2.5の配布法・ライセンスの種類
PyMOLは、オープンソースの分子ビューアソフトで、現在はSchrödinger社によって開
発・管理が行われています。配布には、オープンソース版とIncentive PyMOLに分かれ
ています。Incentive PyMOLにはいくつかのライセンスの種類があります。

配布法 ライセンス 費用 説明

オープンソース ---- 無料 機能制限あり。ソースのみ無料
配布のため、自分でコンパイルす
るか、コンパイル済みバイナリを公
開している第3者のサイトからダウ
ンロードする必要。

incentive ライセンスなし 無料 機能制限あり。30日間の限定
使用。”No License File”の表示

Commercial 要問合せ

Government $199/1人,
年

Academic/Non-profit $99/1人,
年

Student/Teacher 
(Education-use-only)

無料 機能制限あり。”Educational 
Use Only”の表示。
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今回の講習会用だけ
の使用なら、

「ライセンスなし」か
「Student/Teacher」ライ
センスを
使ってください



本気で研究に使う場合は、
ライセンスの購入を推奨いたします
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PyMOLの起動
(1)スタートメニューからPyMOL(pymol)を選ぶ

(2) Skip Activationを選ぶ (3) 「ライセンスなし」
のPyMOLが起動

※ただし、機能限定版。使
用日数の制限もあり。また、
画面に常に
“No License File”
と表示される。 17



PDB ID:2ht7をGetPDBでfetchする
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(1) [File]→[GetPDB…]を選ぶ (2) PDB ID:に2ht7と入力。[Download]をクリック



PyMOLのウィンドウ構成
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コマンドライン

コマンドライン

オブジェクトパネル

Action
Show
Hide
Label
Color



マウスの使い方
表示法 PyMOL UCSF Chimera Molmil

分子の回転 左ボタンで画面をド
ラッグ

左ボタンで画面をド
ラッグ

左ボタンで画面をド
ラッグ

分子の並進 中ボタン（ホイー
ル）で画面をドラッ
グ

中ボタン（ホイール）で
画面をドラッグ

(1)中ボタン（ホイー
ル）で画面をドラッグ
(2)[Shift]キー+左ボタ
ン

ズームイン・
アウト

右ボタンで画面をド
ラッグ

(1)右ボタンで画面をド
ラッグ
(2)ホイールを回す

(1)右ボタンで画面を
ドラッグ
(2)ホイールを回す

断面の表示
(slab)

ホイールを回す [Tools]→[Viewing 
Controls]→[Side View]

[View]→[Configure 
slab]

残基名・原
子名の確認

左ボタンで原子をク
リックすると、アッ
パーコントロール・
ウィンドウに表示

画面上で原子の上に
マウスポインタをしば
らくかざしておくと、原
子名のラベルが表示

左ボタンで原子をク
リックすると、画面下
に表示
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PyMOL 選択コマンド
書式 例 意味
[実行], chain [鎖] color red, chain A A鎖を赤に
[実行], resn [残基名] color red, resn CYS システインを赤に
[実行], atom [原子名] color red, atom CB Cb原子を赤に
[実行],resi [番号] color red, resi 104 104番目の残基を赤に
[実行],resi [番号]+[番号] color red, resi 104+212 104番目と212番目の残基を赤に

[実行],resi [番号]-[番号] color red, resi 104-212 104～212番目の残基を赤に

[実行],chain [鎖] & resn [残基名]

& atom [原子名]

color red, chain A & resn CYS

& atom CB

A鎖のシステインのCb原子を赤に

[実行],[鎖]/[残基名]/[原子名] color red, A/CYS/CB A鎖のシステインのCb原子を赤に

[実行],chain [鎖]& resi=[番号] color red, chain A & resi 104 A鎖の104番目を赤に

[実行],[鎖]/[番号]/ color red, A/104/ A鎖の104番目を赤に
[実行],[条件] around [距離] color red, resn ATP around 5 ATPから5Å以下の原子を赤に

[実行],byres([条件] around [距離]) color red, byres (resn ATP

around 5)

ATPから5Å以下の残基を赤に

[実行], [条件] & [条件] color red, polymer & resi

104

高分子の104番目を選択

[実行], [条件] | [条件] color red, resn SER | resn

THR
セリンかスレオニンを赤に

[実行], [条件] [値]+[値] color red, resn SER+THR セリンかスレオニンを赤に

[実行], polymer color red, polymer 高分子を赤に
[実行], organic color red, organic 有機低分子化合物を赤に
[実行], solvent color red, solvent 水分子を赤に
select [選択原子名],[条件] select actsite,resi 104 104番目をactsiteと命名



PyMOL 実行コマンド

書式 例 意味

show [表示法] show sphere 球モデルの非表示

hide [表示法] hide sphere 球モデルの表示

※ [表示法]は、球：sphere、線：lines、スティック：sticks、リボン：ribbon、カートゥーン:cartoon、表
面：surfaceを使うことができる。

color [色] color blue 青色にする

util.cbag 元素ごとに色分けする

bg_color [色] bg_color white 背景を白に

rotate [xyz] [回転角（°）] rotate y 180 Y軸のまわりに180°回転

reset 分子を元の向きに戻す



PyMOL Wiki https://pymolwiki.org/index.php/Main_Page

PyMOLのマニュアル、チュートリアルに加え、様々なPyMOL Scriptのライブラリがある

Pythonスクリプトをダウンロードして
[File]→[Run Script…]で選択して実行すると、
新しいコマンドが使えるようになる



UCSF Chimera
・UCSF (カリフォルニア州立大サンフランシスコ校)の Thomas Ferrinの
研究室で開発

・NIH(アメリカ国立衛生研究所)の研究費を用いて開発

・Windows版、Mac版、Linux版の実行バイナリを配布

・非商用(Non-commercial)な使用のみ無償。商用目的は有償で別
途ライセンス契約を結ぶ必要

・電子顕微鏡の３Dマップの表示・操作
の機能が充実

・次期プログラムChimera Xの開発が進行中

2014/02/19 Ferrin研でTom Goddardと



Data processing for EM Single Particle Analysis

2D images 3D image Atomic model
3D reconstruction Atomic modeling

emd_9973.map

22.24 MB
PDB_ID: 6kfh

1.7 MB

EMPIAR-10291

EMPIAR
EMDB wwPDB

(3.6Å)300 images
3710 x 3838 x 1; 32 bit real

180 x 180 x 180 voxels 20840 atoms

EMPIAR-PDBj

INX-6

15.9 GB

300 movies
3710 x 3838 x 30; 32 bit real 478 GB

(not registered in EMPIAR.
personal communication) 25



電顕で決定された原子モデル３Dマップを重ねて観察
PDB_ID: 2c7e EMDB_ID:1047 (9.7 Å; 1283 voxels)

UCSF Chimeraを起動

contourLevel : 0.0839



原子モデル(PDB ID:2c7e)をfetchして表示

(1)[File]→[Fetch by ID]

(2)[PDB (mmCIF)]に2c7e

(3) 2c7eの原子モデルが表示

(4)[Tools] →[Depiction] →[Rainbow]

(5)[chain]を選んで [OK] 

(6) 鎖ごとに色分け

(7)[Actions] →[Atoms/Bonds] →[Show]

→原子がワイアで表示される



3Dマップ(EMDB:1047)をfetchして表示
(1)[File]→[Fetch by ID]

(2)[EMDB]に1047

(3) 1047の3Dマップが表示

(4)[Tools] →[Volume Data] 
→[VolumeViewer]

(5) stepを1にする

(6) Levelを0.0839にする



3Dマップを透明にする方法
(1)VolumeViwerのStyleを

”mesh”に

(2)VolumeViwerのStyleを”surface”にして
Colorの□をクリック、”A”の値を0.5にする

分解能9.7 Åなので
ドメイン程度まで判別できる



原子モデル・3Dマップを隠す方法
(1)[Favorites]→[Model Panel]

(2)[Model Panel]が表示される

(3)2c7eの☑をはずす

(4)マップ(emd_1047.map)だけが表示される

※AはActive, SはShowを表す



PDB ID:5w0s, EMDB:8750も見てみましょう
PDB_ID: 5w0s EMDB_ID: 8750 (3.5 Å; 2403 voxels)

contourLevel : 0.04

分解能3.5 Åなので
二次構造まで判別できる



UCSF Chimeraのコマンドライン

(1)[Favorites]→[Command Line]
(2) Command:にコマンド
(例えば、rainbow chain)を入力



UCSF Chimera 選択コマンド
書式 例 意味
[実行] :.[鎖] color red :.A A鎖を赤に
[実行] :[残基名] color red :CYS システインを赤に
[実行] @[原子名] color red @CB Cb原子を赤に
[実行] :[残基名]@[原子名]:[鎖] color red :CYS.A@CB A鎖のシステインのCb原子を赤

に
[実行] :[番号] color red :104 104番目の残基を赤に
[実行] :[番号],[番号] color red :104,212 104番目と212番目の残基を赤

に
[実行] :[番号]-[番号] color red :104-212 104～212番目の残基を赤に
[実行] :[番号]-[番号].[鎖] color red :104-212.A A鎖の104～212番目を赤に
[実行] :[条件] za<[距離] color red :ATP za<5 ATPから5Å以下の原子を赤に
[実行] :[条件] zr<[距離] color red :ATP zr<5 ATPから5Å以下の残基を赤に
[実行] [条件] and [条件] select protein and 104 タンパク質の104番目を選択
[実行] :[条件] or :[条件] color red :SER || :THR セリンかスレオニンを赤に
[実行] protein color red protein タンパク質を赤に
[実行] nucleic acid color red nucleic acid 核酸を赤に
[実行] ligand color red ligand リガンド分子を赤に
[実行] solvent color red solvent 水分子を赤に



UCSF Chimera 実行コマンド
書式 例 意味
display と ~display 原子の表示と非表示
ribbon と ~ribbon リボンモデルの表示と非表

示
surface と ~surface 分子表面の表示と非表示
repr sphere 原子を空間充填モデルで
repr wire 原子をワイアフレームモデ

ルで
repr stick 原子をスティックモデルで
repr bs 原子をボール＆スティックで

color [色] color blue 青色にする
color byelement 元素ごとに色分けする
rainbow chain 鎖ごとに虹色に
rainbow residue N末からC末へ虹色に
set bg_color [色] set bg_color white 背景を白に
turn [xyz] [回転角（°）] turn y 180 Y軸のまわりに180°回転
reset 分子を元の向きに戻す



PyMOL・UCSF Chimeraの操作法などが
載っている本

見てわかる 構造生命科学 ―生命科学
研究へのタンパク質構造の利用―

中村春木 編 化学同人 2014年 税抜
5000円

RasMol,  UCSF Chimera, PyMOLの
使い方を解説



Molmil
• PDBjのGert-jan Bekker氏が開発した分子ビューア

• ブラウザ内で分子を表示。WebGLを使用

• インストール作業が不要

• JavaScriptで開発

• ブラウザ内の標準的なビューアJSmolに比べて、表示がき
れいで動作が速い

•自分のWEBページに３次元の分子をかざることができる

• mmCIFファイルにきちんと対応

36

Gert-jan Bekker

Gert-Jan Bekker, Haruki Nakamura & Akira R. Kinjo.  Molmil: a molecular viewer for the 
PDB and beyond. Journal of Cheminformatics  8, Article number: 42 (2016) 



ノイラミニダーゼのPDBの構造の観察

(2)PDB_ID: 2ht7のページが表示される

2ht7 chain A: UniProt: NRAM_I63A3
Neuraminidase  EC=3.2.1.18  GN Name=NA 
Influenza A virus (strain A/Duck/Ukraine/1/1963 H3N8).

-!- FUNCTION: Catalyzes the removal of terminal sialic acid residues from  viral and cellular 
glycoconjugates. Cleaves off the terminal sialic acids on the glycosylated HA during virus budding to 
facilitate virus release. -!- CATALYTIC ACTIVITY: Reaction=Hydrolysis of alpha-(2->3)-, alpha-(2->6)-, 
alpha- (2->8)- glycosidic linkages of terminal sialic acid residues in  oligosaccharides, glycoproteins, 
glycolipids, colominic acid and  synthetic substrates.; EC=3.2.1.18; -!- SUBUNIT: Homotetramer. 

37

(1) https://pdbj.orgのフォームに2ht7と入力

2ht7

(4)molmilによる2ht7の表示

(5)[Style menu]->[Hide]でスタイルメニューを消せます

(3) [非対称単位を表示]をクリック



メニューによる表示の変更

左クリック

左クリック

右クリック

Display:
Ca trace

Color:
structure

38



コマンドラインの表示

（１）メニューアイコン
を左ボタンでドラッグし、
[Toggle CLI]を選ぶ

（２）Pymol-like command line interfaceが表示される

ここにコマンドを入力

CLI : 
Command Line Interface

PyMOL風のコマンドを入力できる

あるいは、画面下の をクリック

をクリックすると
コマンドライン
が消える

※もう一度、
[Toggle CLI]を
選ぶと、
コマンドライン
が消える

39



コマンド入力:リガンド周辺原子の表示

hide cartoon,all #カートゥーン表示をオフ
hide ball_stick,all #スティック表示をオフ
show sticks, byres (resn G39 around 5) #分子G39の周辺5Åの残基を選択
color cpk,all #原子の色をCPKに
show ball_stick, resn G39 #選択した原子を、太さ50のワイアフレームで表示

コマンドラインインターフェースに以下のコマンドを入力する

原子をマウス左ボタンでクリックする
と、その残基名・残基番号・原子名
が、左下に表示される

ARG371

ILE371

ARG152

ASP151

ARG118

GLU119

ALA246

PDB_ID:2HT7のG39周辺の構造
TYR406

ASP151, TYR406は活性部位
(UniProt: NRAM_I63A3)
ASP151: Proton Donor/Acceptor

TYR406: Nucleophile

40

塩橋

水素結合

疎水結合

スペースを必ず入れること！

G39



MolmilコマンドとPyMOLコマンドの違い

41

1. “,all”が必要

2. “color”と”cartoon_color”を区別

hide cartoon×

hide cartoon,all〇

何も起きない…

カートゥーンが消えてくれる！

color red,all×

cartoon_color red,all〇

何も起きない…

カートゥーンの色が赤くなる！

デフォルトの蛋白質がカートゥーン表示のときに以下のコマンドを実行する場合



Molmil コマンド早見表 : 選択コマンド

選択コマンドの書式 例 意味
[実行], all show sticks, all 全ての原子を棒表示
[実行], chain [鎖] cartoon_color red, chain A A鎖のカートゥーンを赤に
[実行], resn [残基名] show sticks, resn CYS システインを棒表示
[実行], name [原子名] show spheres, name CB Cβ原子を球表示に
[実行], symbol [元素名] show spheres, symbol S 硫黄元素を球表示に
[実行], entity [エンティティ番号] show spheres, entity 3 エンティティ3を球表示に
[実行], resi [番号] show spheres, resi 104 104番目を球表示に
[実行], resi [番号]-[番号] show spheres, resi 104-212 104～212番目を球表示に
[実行],[条件] around [距離] show sticks, resn ATP around 5 ATPから5Å以下の原子を棒表示に

[実行], byres ([条件] around [距離]) show sticks, byres (resn ATP around 5) ATPから5Å以下の残基を棒表示に

[実行], [条件] and [条件] show spheres, chain A and resi 104 A鎖の104番目を球表示に

[実行], [条件] or [条件] show sticks, resn SER or resn THR セリンかスレオニンを棒表示に

[実行], hetatm show spheres, hetatm HETATMを球表示に
[実行], hydro show spheres, hydro 水分子を球表示に
[実行], snfg show cartoon, snfg SNFG表示可能な糖鎖をカートゥーン

に
select [選択原子名],[条件] select actsite,resi 104+212 104と212番目をactsiteと命名
[実行], [選択原子名] show spheres, actsite 選択したactsiteを球表示に

42



Molmil コマンド早見表 : 実行コマンド

43

実行コマンドの書式 例 意味

show [表示法] show spheres, all 球モデルの非表示

hide [表示法] hide spheres, all 球モデルの表示

※ [表示法]は、球：spheres、線：lines、スティック：sticks、ボール&スティック：ball_stick, カートゥーン:cartoon, バック
ボーン：ca-trace, SNFGとスティック:snfg-icon

color [色] color blue, all 青色にする

cartoon_color [色] cartoon_color red, all カートゥーンの色を赤にする

color [r,g,b] color [0,255,255],all シアン色[0,255,255]にする

color cpk color cpk, all 元素ごとに色分けする

※次の[色]も使用できる。N末からC末へ青から赤:group、二次構造による色分け:structure、温度因子による彩色:bfactor

bg_color [色] bg_color white 背景を白に

turn [xyz], [回転角（°）] turn y, 180 Y軸のまわりに180°回転

reset reset 分子を元の向きに戻す

set cif_use_auth,[onかoff] set cif_use_auth,off label_asym_id を 鎖 識 別 子 に 、
label_seq_idを残基番号に



WEBアドレス１行で構造が表示できる

https://pdbj.org/molmil2/#fetch 2ht7;

https://pdbj.org/molmil2/#fetch 2ht7;cartoon_color group,all;show spheres, resn G39;

WEBブラウザのアドレスに以下のコマンドを打つだけで構造を表示できます

#の後に、Molmilのコマンドをセミコロン(;)区切りで入力することができます

電子メールやブログなどで、簡単に指定した表示の立体構造へのリンクを示すことができる



Molmilを組み込んだシンプルなWEBページ

<html>

<head>

<script src="https://pdbj.org/molmil2/molmil.js"></script>

<script>  

var molmil_settings = {src: "/molmil2/"}, canvas;

function initViewer() {

canvas = document.getElementById("molmilViewer");

molmil.autoSetup();

molmil.loadPDB("2ht7", null, null, canvas.molmilViewer);

canvas.commandLine.run("cartoon_color group, all;show spheres, resn G39;");

}

</script>

</head>

<body onload="initViewer();">

<center>

<h3>Molmil simple page (2ht7)</h3>

<span class="molmil_UI_container">

<canvas id="molmilViewer" width="600" height="400"></canvas> 

</span>

</center>

</body>

</html>

https://numon.pdbj.org/binds_workshop_202109/molmil_simple_2ht7.html

PDBjサーバから2ht7を取得

Molmilのコマンドをここに記入



Molmilを組み込んだボタン付きWEBページ

<html>

<head>

<script src="https://pdbj.org/molmil2/molmil.js"></script>

<script>  

var molmil_settings = {src: "/molmil2/"}, canvas;

function initViewer() {

canvas = document.getElementById("molmilViewer");

molmil.autoSetup();

canvas.molmilViewer.loadStructure("2ht7_in_this_server.pdb","pdb");

canvas.commandLine.run("cartoon_color group, all;show spheres, resn G39;"); 

}

function show_G39(boolEnable){

if (boolEnable){ canvas.commandLine.run("show spheres, resn G39;"); }

else{ canvas.commandLine.run("hide spheres, resn G39;"); }

}

</script>

</head>

<body onload="initViewer();">

<center>

<h3>Molmil advanced page (2ht7)</h3>

<span class="molmil_UI_container">

<canvas id="molmilViewer" width="600" height="400"></canvas>

</span>

<BR> <input type="checkbox" onclick="show_G39(this.checked)" checked>show G39

</center>

</body>

</html>

https://numon.pdbj.org/binds_workshop_202109/molmil_advanced_2ht7.html

Webサーバに置いたPDBファイルを読み込む

G39を球表示したり、隠したりする関数

checkboxをクリックすると、関数show_G39()を呼び出すように設定



Molmilを活用したWEBページ

https://numon.pdbj.org/binds_workshop_202109/osawa/
（１）本講習会の大澤先生の発表のWEBページ

（2）一般向けコロナウィルスの解説ページ
生命をささえるタンパク質の「かたち」 -新型コロナウィルスの立体構造 -

https://numon.pdbj.org/covid19

YouTubeに解説動画もあります

https://www.youtube.com/user/PDBjmovie


