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Data processing for EM Single Particle Analysis

2D images 3D image Atomic model
3D reconstruction Atomic modeling

emd_9973.map

22.24 MB
PDB_ID: 6kfh

1.7 MB

EMPIAR-10291

EMPIAR
EMDB wwPDB

(3.6Å)300 images
3710 x 3838 x 1; 32 bit real

180 x 180 x 180 voxels 20840 atoms

EMPIAR-PDBj

INX-6

15.9 GB

300 movies
3710 x 3838 x 30; 32 bit real 478 GB

(not registered in EMPIAR.
personal communication)



Summary of innexin-6 EM data

EMPIAR EMDB Resol
ution

PDB molecules Details of EMPIAR Data size of EMPIAR entry

10289 9971 3.8
Å

6kff WT INX-6 
in a 
nanodisc

Motion corrected 2D projection 
images of innexin-6 gap 
junction hemichannels in 
nanodiscs.

49.5 GB.   933 *.mrc files.  
Each mrc files has 3710 x 
3838 x 1 pixels.

10290 9972 3.8
Å

6kfg WT INX-6 
in a 
detergent

Motion corrected 2D projection 
images of innexin-6 gap 
junction hemichannels in 
detergent.

26.4 GB.   497 *.mrc files.  
Each mrc files has 3710 x 
3838 x 1 pixels.

10291 9973 3.6
Å

6kfh WT INX-
6ΔN in a 
nanodisc

Motion corrected 2D projection 
images of N-terminal deleted 
innexin-6 gap junction 
hemichannels in nanodisc.

15.9 GB.   300 *.mrc files.  
Each mrc files has 3710 x 
3838 x 1 pixels.

Batuujin Burendei, Ruriko Shinozaki, Masakatsu Watanabe, Tohru Terada, Kazutoshi Tani,*, Yoshinori Fujiyoshi and Atsunori Oshima. 
Cryo-EM structures of undocked innexin-6 hemichannels in phospholipids. Science Advances  12 Feb 2020: Vol. 6, no. 7, eaax3157 
DOI: 10.1126/sciadv.aax3157 

・EMPIARに登録されているのはMotionCorrection後の静止画像のみ

・undocked hemichannelはEMPIAR, EMDB,PDBで公開。Docked hemichannelは、EMDB (9570, 
9571),  PDB(5h1q, 5h1r)で公開されているが、EMPIARにはデータがない。
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JEM-3000SFF(JEOL)
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The data were collected using a JEM-3000SFF (JEOL) electron microscope at 300 kV 
equipped with a K2 summit direct electron detector camera (Gatan).

Gatan社製K2 Summit直接検出型カメラ

Burendei, B.,Shinozaki, R.,Watanabe, M.,Terada, T.,Tani, K.,Fujiyoshi, Y.,Oshima, A. Sci Adv, 6:eaax3157-eaax3157, 2020

+



Innexin-6 : docked and undocked states

EMD-9973/PDB_ID:6kfh EMD-9570/PDB_ID:5h1q EMD-9571/PDB_ID:5h1r

EMPIAR-10291

Undocked innexin-6
hemichannel

Docked innexin-6

117 A

1
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7
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1
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5
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Oshima, A.,Tani, K.,Fujiyoshi, Y.Nat Commun, 7:13681-13681, Burendei, B.,Shinozaki, R.,Watanabe, 
M.,Terada, T.,Tani, K.,Fujiyoshi, Y.,Oshima, A.
Sci Adv, 6:eaax3157-eaax3157, 2020

Structural component of the gap junctions.



ギャップ結合 (gap junction)
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ギャップ結合（ギャップけつごう、英: Gap junction）は、隣り合う上皮細胞をつなぎ、水溶性の小さいイオ
ンや分子を通過させる細胞間結合のこと。並んだ2つの細胞の細胞膜にはコネクソンと呼ばれるタンパ

ク複合体の末端が複数並んでおり、橋渡し構造をなしている。このコネクソンがチャネルとなり、ここを
通って無機イオンや小さい水溶性分子が隣接細胞の細胞質から細胞質へと直接移動することができる。
また、細胞同士を電気的に結合するため、心筋組織などの興奮伝播にも関わっている。

Wikipediaからの引用

Gap junctions are a specialized intercellular connection between a multitude of animal cell-types. They directly 
connect the cytoplasm of two cells, which allows various molecules, ions and electrical impulses to directly pass 
through a regulated gate between cells. One gap junction channel is composed of two connexons (or 
hemichannels), which connect across the intercellular space. Gap junctions are analogous to 
the plasmodesmata that join plant cells.

https://ja.wikipedia.org/wiki/%E8%8B%B1%E8%AA%9E
https://ja.wikipedia.org/wiki/%E4%B8%8A%E7%9A%AE%E7%B4%B0%E8%83%9E
https://ja.wikipedia.org/wiki/%E3%82%A4%E3%82%AA%E3%83%B3
https://ja.wikipedia.org/wiki/%E5%88%86%E5%AD%90
https://ja.wikipedia.org/wiki/%E7%B4%B0%E8%83%9E%E9%96%93%E7%B5%90%E5%90%88
https://ja.wikipedia.org/wiki/%E7%B4%B0%E8%83%9E
https://ja.wikipedia.org/wiki/%E7%B4%B0%E8%83%9E%E8%86%9C
https://ja.wikipedia.org/wiki/%E3%82%B3%E3%83%8D%E3%82%AF%E3%82%BD%E3%83%B3
https://ja.wikipedia.org/w/index.php?title=%E3%82%BF%E3%83%B3%E3%83%91%E3%82%AF%E8%A4%87%E5%90%88%E4%BD%93&action=edit&redlink=1
https://ja.wikipedia.org/wiki/%E3%82%A4%E3%82%AA%E3%83%B3%E3%83%81%E3%83%A3%E3%83%8D%E3%83%AB
https://ja.wikipedia.org/wiki/%E7%B4%B0%E8%83%9E%E8%B3%AA
https://en.wikipedia.org/wiki/Cell_(biology)
https://en.wikipedia.org/wiki/Cytoplasm
https://en.wikipedia.org/wiki/Molecule
https://en.wikipedia.org/wiki/Ion
https://en.wikipedia.org/wiki/Connexon
https://en.wikipedia.org/wiki/Plasmodesmata


Undocked innexin-6 hemichannel

EMPIAR-10289

1
1

7
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EMPIAR-10290 EMPIAR-10291

EMD-9971/PDB_ID:6kff EMD-9973/PDB_ID:6kfhEMD-9972/PDB_ID:6kfg

WT INX-6 in a nanodisc WT INX-6 in a detergent WT INX-6ΔN in a nanodisc



nanodisc
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To investigate the structure in a lipid bilayer, 

we reconstituted undocked WT INX-6 

hemichannels in nanodiscs using the 

membrane scaffold protein 2N2 (MSP2N2) 

and 1-palmitoyl-2-oleoyl-sn-glycero-3-

phosphocholine (POPC), as confirmed by 

Coomassie brilliant blue–stained gel and 

negatively stained electron micrographs (fig. 

S1A). 
Burendei, B.,Shinozaki, R.,Watanabe, M.,Terada, 
T.,Tani, K.,Fujiyoshi, Y.,Oshima, A.
Sci Adv, 6:eaax3157-eaax3157, 2020

PDB_ID: 1av1
Apolipoprotein A-1
(APOA1_HUMAN)



INX6hemiNano001

After CtfFind, 
SigmaContrast:3
Lowpass filter 10 Å

Pixel_width: 1.232Å

EMPIAR-10289
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These long circles
are not proteins.
micelle ? Nanodiscs ?

WT INX-6 in nanodisc



INX6hemiDet002

After CtfFind, 
SigmaContrast:3
Lowpass filter 10 Å

Pixel_width: 1.232Å

EMPIAR-10290
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WT INX-6 in detergent



INX6hemiDet001

After CtfFind, 
SigmaContrast:3
Lowpass filter 10 Å

Pixel_width: 1.232Å

EMPIAR-10291
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WT INX-6DN in nanodisc



Download tutorial data

12

1) Googled by “EMPIAR PDBj” 2) Click [Workshop] at the header

3) Download “EMPIAR-10291_50mic.tar”  (2.7 GB)



cryoSPARCプログラム

• トロント大学計算機科学科で2017年に最初の版が公開・
出版

•現在、Vector InstituteとStructura Biotechnology Inc.の二
つの企業によって、開発・配布・販売

• アカデミックな利用は無料だが、商用目的は有料

• ソースは非公開

• GPU、複数コア、複数ノードによる並列計算環境を想定

• Webサーバから、計算ジョブを投入するインターフェース

13



Structura Biotechnology Inc.
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https://structura.bio



15https://www.youtube.com/watch?v=eRPue0-Pkw4&t=3152s



16https://www.youtube.com/watch?v=eRPue0-Pkw4&t=3152s



Articles of cryoSPARC
Articles Comment

Punjani A, Rubinstein JL, Fleet DJ, Brubaker MA.
cryoSPARC: algorithms for rapid unsupervised cryo-EM structure 
determination. Nat Methods. 2017 Mar;14(3):290-296. doi: 
10.1038/nmeth.4169. 

Stochastic Gradient 
Descent

Punjani A,  Brubaker MA,  Fleet DJ. Building Proteins in a Day: 
Efficient 3D Molecular Structure Estimation with Electron 
Cryomicroscopy. IEEE Transactions on Pattern Analysis and Machine 
Intelligence, 2017, vol. 39, no. 4, 706-718, 1 April 2017, doi: 
10.1109/TPAMI.2016.2627573.

Punjani A, Zhang H, Fleet DJ. Non-uniform refinement: adaptive 
regularization improves single-particle cryo-EM reconstruction. Nat 
Methods. 2020 Dec;17(12):1214-1221. doi: 10.1038/s41592-020-
00990-8.

Non-uniform refinement

Punjani A, Fleet DJ. 3D variability analysis: Resolving continuous 
flexibility and discrete heterogeneity from single particle cryo-EM.  J 
Struct Biol. 2021 Feb 11;213(2):107702. doi: 
10.1016/j.jsb.2021.107702

3D variability analysis

Punjani A, Fleet DJ. 3D Flexible Refinement: Structure and Motion of 
Flexible Proteins from Cryo-EM.  bioRxiv 2021 doi: 
https://doi.org/10.1101/2021/04.22.440893

3D flexible refinement
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https://doi.org/10.1101/2021/04.22.440893


Who are they ?
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Punjani A,  Brubaker MA,  Fleet DJ. Building Proteins in a Day: Efficient 3D Molecular Structure 
Estimation with Electron Cryomicroscopy. IEEE Transactions on Pattern Analysis and Machine 
Intelligence, 2017, vol. 39, no. 4, 706-718, 1 April 2017, doi: 10.1109/TPAMI.2016.2627573.



Patent ?
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Declaration of Competing Interest
A.P. is CEO of Stuctura Biotechnology Inc. which builds the cryoSPARC software package, 
distributed freely for academic non-profit use with software licenses available for 
commercial use. D.J.F. is an advisor to Stuctura Biotechnology Inc. The novel aspects of 
the method presented are described in a provisional patent application.

Punjani A, Fleet DJ. 3D variability analysis: Resolving continuous flexibility and discrete heterogeneity from single 
particle cryo-EM.  J Struct Biol. 2021 Feb 11;213(2):107702. doi: 10.1016/j.jsb.2021.107702

Competing Interests
The novel aspects of the method presented are described in a provisional patent application.

Punjani A, Fleet DJ. 3D Flexible Refinement: Structure and Motion of Flexible Proteins from Cryo-EM.  bioRxiv 2021 
doi: https://doi.org/10.1101/2021/04.22.440893



Algorithm for 3D reconstruction

E-step M-step

Observed projection images

initial 3D map 

(2) Chose the closest projection
for each observed projection
to estimate its orientation

(1) 2D projections are 
generated from 3D map.

(3) 3D reconstruction is performed
using estimated orientations

PDB ID:5uz7
Resolution: 6 A



3D reconstruction of cryoSPARC
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・3D Refinement : based on Relion-like Bayes estimation framework

E-step： Estimate projection orientation for each 2D particle image

M-step： Reconstruct 3D map from 2D particles images 
using the estimated orientations, in Fourier space.

Input : Prepare an initial 3D map

・E-step : Efficient search of projection orientations 
using Branch and Bound

・M-step : the standard EM algorithm may be employed.

・Ab initio reconstruction: 
M-step: gradient-based algorithm is employed, not EM algorithm.EMア
Furthermore, SGD(Stochastic Gradient Descent) has been introduced.

*SGD: gradient is obtained from a part of particle images, to avoid a trapping into local 
optimum.



Stochastic Gradient Descent for M-step
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Branch-and-bound for E-step
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Hardware required for Relion/cryoSPARC

24

NVIDIA GeForce 1080 Ti

I am buying new GPUs, what do you recommend to run RELION on?
Our collaborator in Stockholm, Erik Lindahl, has made a useful blog with GPU hardware recommendations. Briefly, you'll need an NVIDIA 
GPU with a CUDA compute ability of at least 3.5, but you don't need the expensive double-precision NVIDIA cards, i.e. the high-end gamer 
cards will also do, but do see Erik's blog for details! Note that 3D auto-refine will benefit from 2 GPUs, while 2D and 3D classification can be 
run just as well with 1 GPU. Apart from your GPUs you'll need a decent amount of RAM on the CPU (at least 64Gb), and you may also 
benefit from a fast (e.g. a 400Gb SSD!) scratch disk, especially of your working directories will be mounted over the network connecting 
multiple machines. 

OS : Linux。GPU用のライブラリとしてCUDAが必要。
GPU の種類: NVIDIA社製。ゲーム用の安価なカードでかまわない。GeForce 1080など。高価な倍精
度のGPU(例えば、Tesla)は必要ない。
GPUの枚数：2D分類は1枚でも動く。3D auto-refineは２枚以上必要。
主メモリ：できるだけ多く。最低でも64Gbyte。
ディスク：scratch領域にSSDがあるとよい。
CPU: CPUだけしか動かないタスクもあるので、コア数も多いほうがよい。

・事前にインストールが必要なライブラリ
・CUDA (GPU計算のためのライブラリ)
・openmpi (ジョブ並列用のライブラリ)

・以下のライブラリは無ければ、relionのコンパイラがインストール時にローカル
にインストールする。
・FFTW (高速フーリエ変換のライブラリ)
・FLTK (GUIのライブラリ)

NVIDIA GeForce RTX™ 2080 Ti

This tutorial assumes 2 persons share 1 Linux machine with 4GPUs.

http://www.cryoem.se/relion-gpu
https://en.wikipedia.org/wiki/CUDA#GPUs_supported


ライセンス IDの取得
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(1) non-profit academic useに限り無料

(2) 申請すると24時間以内に登録メール
アドレスにライセンスIDが送付される

(4)一つのライセンスIDでは、一つの
masterノードしかインストール・実行でき
ない。

(5)研究室などで、複数の人が共有で使
用する場合は、Master-workersかCluster
の様式でセットアップする必要

(3) 登録メールアドレスとして、
@gmail.comや@yahoo.co.jpを入れると
即座にPlease enter a valid 
institution/company email addressという
エラーで棄却。@docomo.ne.jpでは受け
付けられるがライセンスIDが送付されて
こない….



Install: Single Workstation Setup
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Master and worker can run on the same 
machine.

Simplest setup.



Install:  Master Workers Setup
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master-workshop
(192.168.39.72)

embox1
(192.168.39.130)

embox3
(192.168.39.90)



Install:  Cluster Setup
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Hardware Requirements
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Component Minimum Requirement Recommended

CPU 4+ cores 8+ cores at 2.8GHz+

RAM 16GB+ 32GB DDR4

Fast Local Storage Not Required Not Required

GPU Not Required Not Required

Network
1Gbps link to storage 
servers

10Gbps link to storage 
servers

Master node

Component Minimum Requirement Recommended

CPU 2+ cores per GPU 4 cores per GPU

CPU Memory Bandwidth 50+ GB/s 100+ GB/s

RAM 32GB+ per GPU 64GB DDR4 per GPU

Fast Local Storage 1TB SSD 2TB PCIe SSD

GPU
1+ NVIDIA GPU with CC 
3.5+, 11GB+ VRAM

1+ NVIDIA Tesla V100, 
RTX2080Ti, RTX3090, etc

Network
1Gbps link to storage 
servers

10Gbps link to storage 
servers

Worker node

https://developer.nvidia.com/cuda-gpus#compute


Software Requirements
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Component Requirement

Operating System Modern Linux OS (Ubuntu)

Shell Bash

User Account cryosparcuser

Software
CUDA ≥10 (worker nodes only)
GCC

Filesystem
Shared file system across all 
nodes

(1) OSはUbuntuを強く推奨。CentOS7では
エラーの報告があるらしい。

(2) Masterノードのインストール・使用ごと
に１つのライセンスが必要。

Master-worker setupの場合の設定について

(1)Master, workersで共通のアカウント cryosparcuserを設定

(2) cryosparcuserはmasterからworkersへパスワード無しでsshログイン可能とする

(3) ポート番号39000-39010が開放されていること(ubuntuはデフォルトが開放状態)

(4) master, workers間で読み書きのできる共有のファイルシステム

https://ubuntu.com/download/desktop
https://www.gnu.org/software/bash/
https://developer.nvidia.com/about-cuda
https://packages.ubuntu.com/bionic/build-essential


CryoSPARCのユーザーアカウント
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(1) 実行にはcryoSPARCのアカウントが必要。Unixアカウントとは別。

(2) cryoSPARCのアカウントは Emailアドレスとパスワード

(3) どのcryoSPARCのアカウントで操作しても、Unixからみると、
cryosparcuserというUnixアカウントが実行しているように見える。

(4) データのアップロードにcryoSPARCにUnixのアカウントも必要。計算結果のダ
ウンロードはWebからできるが、入力画像のアップロードはWebからできないの
で、WebマシンにUnixアカウントでログインして入力電顕画像のアップロード作
業する必要がある。



今回の講習会用マシンの設定
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(1) 所内用： Master + 2 Workers 所内から http://192.168.39.72:39000

アカウント：
guest01@master-workshop

guest02@master-workshop

guest03@master-workshop

guest04@master-workshop

guest10@master-workshop

計算済みの結果が見れます

master-workshop
(192.168.39.72)

embox1
(192.168.39.130)

embox3
(192.168.39.90)

※４人のアシスタントの方だけに
使っていただきます。

(2) 所外のリモート参加者用： Single Workstation 

embox2
(192.168.39.89)

所内から http://ciclews.pdbj.org

アカウント：
guest01@embox2

guest02@embox2

guest03@embox2

guest04@embox2

guest10@embox2 計算済みの結果が見れます

パスワード(共通)：
embox2remote

※８０人以上の人がアクセスする可能性があるので、くれぐれもジョブを実行しないでください。



リモート受講者用の計算途中結果のデータ提供
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講習会のWEBページ https://pdbj.org/news/workshop20210624

すべて展開
ジョブごとのデータ（電顕画像、３Dマップデータなど）を収納



Job history
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Day 1 ?

Day 2 ?



Comparison with Relion 3.1
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cryoSPARC v3.2.0 Comp. Time Relion 3.1 Comp.Time

J2:Patch CTF estimation 02 min 06 sec CTF estimation < 1min

J4:2D classification 
(100particles)[1GPU]

01 min 03 sec 2D classification
(341 particles) [1GPU]

1 min

J9:Template picker 01 min 06 sec Auto-picking, reference-
based [1GPU]

2 min

J12:2D classification
(27680 particles; 50 class) 
[2 GPUs]

06 min 31 sec 2D classification (38244 
particles; 20 class) 
[2GPUs] 

23 min

J14: Ab-initio 
reconstruction(1283)[1GPU]

05 min 38 sec 3D Initial model (643)[
[1GPU]

10 min

J15: Homogeneous 
Refinement (1803;1class) 
[1GPU]

05 min 20 sec 3D classification 
(643;4classes)
[2GPUs]

12 min

3D refinement (1803;1class) 
[2GPUs] 

25 min



Comp.Time by Single and Four users
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Single user Four users

cryoSPARC v3.2.0 guest10 guest01 guest02 guest03 guest04

machines embox3 embox3 embox1

J2:Patch CTF estimation 02:06 02:08 02:07 02:21 02:20

J4:2D classification 
(100particles)[1GPU]

01:03 01:06 01:15 01:03 01:18

J9:Template picker 01:06 01:03 02:30 02:25 01:54

J12:2D classification
(27680 particles; 50 class) 
[2 GPUs]

06:31 11:26 11:33 14:56 14:34

J14: Ab-initio 
reconstruction(1283)[1GPU]

05:38 09:30 09:34 04:48 04:54

J15: Homogeneous Refinement 
(1803;1class) [1GPU]

05:20 06:33 08:08 05:23 05:10

*2D class and Template picker job with 4 users takes ~2 times time than those with 1 user.
This may due to DISC I/O; 4 users access to one shared_disc in the master node.



Step 0: Log-in 
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http://192.168.39.72:39000

guest01@master-workshop



Step 1: Create a Project
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(1) Click [Projects] icon

(2) Click [+ Add] button

(3) Input “Title” and “Directory in which to create new project directory”
(4)

EMPIAR-10291_50mic

/shared_data_SSD4TB/cryosparc_projects/guest10

Project directory must exist.
Project directory must be in the shared directory. 



Step 2: Create a Workspace
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(1) Click your Project number

(3) Input Title of a new Workspace

(4)  A new workspace is shown.

(2) Click[+ Add]

Test Workspace



Download Tutorial Data by Command
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(1) Log-in to the “master” server.

$ cd /shared_data_SSD4TB/cryosparc_projects/guest01

(2) Change directory  to your project directory

(3) Change directory  to your project directory

$ wget ftp://empiar.pdbj.org/pub/empiar/workshop/10291/00001/EMPIAR-

10291_50mic.tar

(4) Extract the tar file

$ tar xvf EMPIAR-10291_50mic.tar

※この作業は今回は不要です。masterサーバの
/shared_data_SD4TB/tutorial_data/EMPAR-10291_50mic

にコピー済みです。



Step 4:  J1:Import Micrographs
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(1)Click a Workspace

(3) Select [Input Micrographs]

(5) Click [Create]

/shared_data_SSD4TB/tutorial_data/EMPIAR-10291_50mic/data/*.mrc

1.232

300

1.6

35.0

NOTE: file extension, such as *.mrc, *.tif, 
has to be added.

(2) Choose [Job Builder]

(4) Input “Micrographs data path”
and other parameters.

then click [Queue]



Step 4: J1:Import Micrographs
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Step 6: J2:CTF estimation (2.5 min with 1GPU)
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(1) Select [Patch CTF estimation(multi)] job

(2) Select previous [Import Micrographs] job



Step 6: J2:CTF estimation  (2.5 min with 1GPU)
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Drag and drop !

(1)

(3) Click [Create]

(2) Set Number of GPU 1
and click [Queue]

Number of GPU:1



Step 6: J2:CTF estimation  (2.5 min with 1GPU)



Step 7: J3 Manual Picker 

(3)Drag and drop !

(1) Choose [Manual Picker] Job

(2) Select CTF estimation Job

(4) Click [Queue](5) Click [Create]



Step 7: J3: Manual Picker  

(1) Choose [Interactive] 

(2) Set Low pass filter (A)=10, and Box size(px)=180 (3) Pick particles by clicking the 
left button of your mouse. At 
least 100 particles should be 
picked from the first 4 
micrographs.  About 25 particles 
per one micrograph.

NOTE: Click the right mouse 
button un-pick a particle.



Box size of particles
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160Å

221.8Å

Diameter

Box size

Pixel size: 1.232Å

180 pixel

160Å

221.8Å

Diameter

Box size

Pixel size: 3.465Å

64 pixel

To reduce 
Computation costs

Just before 
Refine3D



1.67 cm : 50Å

マスク直径5.28cm = 158.08Å

方形の１辺7.44cm = 222.75Å

Burendei et al. Science Advances. 2020. DOI: 10.1126/sciadv.aax3157 Fig.S3c
2D Class average images from the original article
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160Å

221.8Å

Diameter

Box size

Pixel size: 1.232Å

180 pixel



Step 7: J3:Manual Picker  



Step 7: J3:Manual Picker 



Step 7: J3:Manual Picker 



Step 7: Particle Picking  



Step 7: J3:Manual Picker 



Step 7: J3:Manual Picker 



Step 7: J3:Manual Picker 

(1) After finishing picking, click [Done Picking! Extract Particles]



Step 7: J3:Manual Picker 



Step 8: Template Picking – J4:2D classification 

(1) Choose [2D Classification] Job (2) Click [Manual Picker] Job

(3) Drag “particles” of Manual Picker 
and Drop

(4) Setup parameters

10

1
(5) Click [Create]



Step 8: Template Picking – J4:2D classification 
[1min with 1GPU] 



Step 8: Template Picking – J8:Select 2D classes

(1) Choose [Select 2D classes] Job

(3) Drag “particles” of Class2D and drop to “particles”

Drag “class averages” of Class2D and drop to “templates”

(2) Choose [Class 2D] Job

(4) Click [Queue] (5) Click [Create]



Step 8: Template Picking – J8:Select 2D classes
(1) Click [Interactive]

(2) Select 2-4 good averages for the templates

(3) Click [Done]



Step 8: Template Picking – J9:Template Picker [1min]
(1) Choose [Template picker] Job

(2) Drag “templates_selected” of 
Select 2D and Drop to templates

(3) Drag “exposures” of Patch 
CTF(M) and Drop to micrographs 160

(4) Input Particle diameter 
and click [Queue] and [Create]



Step 8: Template Picking – J9:Template Picker [1min]



Step 9: J10:Inspect Picks

(2) Drag “particles” of Template 
picker and Drop to “particles”

(3) Drag “exposures” of Patch 
CTF(M) and Drop to “micrographs”

(4) Click [Queue] and [Create]



Step 9: J10:Inspect Picks

Low pass filter (A) = 10

Box size (px):180



Step 9:  J10:Inspect Picks

Low pass filter (A) = 10

(1) Set NCC threshold:0.33 (2) Power threshold:700

(3) Click [Done Picking ! Output Locations]

NCC: Normalized Cross Correlation

Power Score: indicating the presence of significant signal



Step 10:  J11:Extract from Micrographs

180

(3) Drag “particles” of Inspect 
Particles and Drop to “particles”

(2) Drag “exposures” of Patch 
CTF(M) and Drop to “micrographs”

(1) Choose [Extract from Micrographs] 
(4) Input Extraction box size(pix)

and click [Queue] and [Create]



Step 10:  J11:Extract from Micrographs

27680 particles



Step 11:  J12:2D Classification [ 6.5 min with 2GPUs]
(1) Choose [2D Classification] job 

(3) Drag “particles” of [Extract From 
Micrograph] and Drop to “particles”

(4) Input Circular mask diameter(A)
and Number of GPUs 

and click [Queue]

2

160

(5) click [Run on specific GPUs]

(6) Check two GPUs assigned for you
and click [Create] 

(2) Click [ExtractFromMicrographs]  
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Step 11:  J12:2D Classification [ 6.5 min with 2GPUs]



Step 12:  J13:Select 2D classes
(1) Choose [Select 2D classes] 

(3) Drag “particles” of [2D Class] 
and Drop to “particles”

(4) Drag “class averages” of [2D 
Class] and Drop to “templates”

(2) Choose [2D class] job 

(5) Click 
[Queue]
and [Create]



Step 12:  J13:Select 2D classes



Step 12:  J13:Select 2D classes

(1) Select “good” classes, considering 
Nparticles and resolution.

(2) Click [Done]

In this case, I selected 11 classes.
It means 16152 particles among 27680 particles.



Step 13: J14:Ab-initio Reconstruction
(1) Choose [Ab-initio Reconstruction] 

(3) Drag “particles_selected” of 
[Select 2D] and Drop to “particles”

(2) Choose [Select 2D] job 

(4) Click [Queue]

(5) click [Run on specific GPUs]

(6) Check one GPU assigned for you
and click [Create] 



Step 13: J14:Ab-initio Reconstruction [5.5 min with 1GPU]

(1) select [Outputs] tab



Step 13: J14:Ab-initio Reconstruction [5.5 min with 1GPU]

(1) Download “J*.volume_class_0.map” 



Step 13: J14:Ab-initio Reconstruction [5.5 min with 1GPU]

Change : step = 1

Change contour Level[File]->[Open…]

[Tools]->[Volume Data]->[Volume Viewer]

1283 1283



Step 14: J15:Homogeneous Refinement
(1) Choose [Homogeneous Refinement] 

(3) Drag “particles_class0” 
of [Ab-initio] and Drop to 
“particles”

(2) Choose [Ab-initio] job 

(4) Click [Queue]

(4) Drag “volume_class0” of [Ab-
initio] and Drop to “volume”

(5) Input Symmetry:C8 and click [Queue]

C8



Step 14: J15:Homogeneous Refinement [5.5 min with 1GPU]

(1) click [Run on specific GPUs] (2) Check one GPU assigned for you
and click [Create] 



Step 14: J15:Homogeneous Refinement [5.5 min with 1GPU]



Resolution from Fourier Shell Correlation (FSC)
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1)Divide 2D particle images into two sets, and reconstruct two ３D maps f1(x) and f2 (x).

Their Fourier transferred maps are called F1(q) and F2 (q). 

2)Calculate correlation FSC(r) on a spherical shell with spatial frequency r=|q|.

3) Plot FSC(r) versus spatial frequency r.  Resolution is defined spatial frequency 
with FSC(r) =0.143 (=1/7). 
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FSC curves in cryoSPARC
Apunjani cryoSPARC Team

Mar '17

Here is a short explanation of the different FSC curves in cryoSPARC:

#FSC calculations in CryoSPARC

##No Mask:

This is the raw FSC calculated between two independent half-maps reconstructed from the data. There is no 

masking applied, so both the structure and solvent are included in this FSC.

##Spherical:

This is the FSC calculated after applying a soft spherical mask to both half maps. The outer radius of the soft 

sphere is equal to half the volume box-size (i.e. the sphere extends to the faces of the box in all directions). The 

inner radius is 85 percent of the outer radius. Between inner and outer radii, a soft cosine edge transitions from a 

mask value of one to a value of zero.

##Loose:

This is the FSC calculated after applying a soft solvent mask to both half maps. The loose mask is calculated as 

follows. First, the density map is thresholded at 50% of the maximum density value. The resulting volume is 

dilated to create a soft mask. Voxels in the mask that are within 25 angstroms of the thresholded region receive 

a mask value of 1.0. Voxels between 25 and 40 angstroms fall off with a soft cosine edge, and voxels outside 40 

angstroms receive a value of 0.0.

##Tight:

This is the same as the loose mask, except the dilation distances are 6 angstroms for the value 1.0 distance and 

12 angstroms for the value 0.0 distance.

##Corrected:

This is the FSC curve calculated using the tight mask with correction by noise substitution [1]. The two half maps 

have their phases randomized beyond a certain resolution, then the tight mask is applied to both, and an FSC is 

calculated. This FSC is used along with the original FSC before phase randomization to compute the corrected 

FSC as in [1]. This accounts for correlation effects induced by masking. The resolution at which phase 

randomization begins is the resolution at which the no-mask FSC drops below the FSC = 0.143 criterion.

1.Chen, S. et al. High-resolution noise substitution to measure overfitting and validate resolution in 3D structure 

determination by single particle electron cryomicroscopy. Ultramicroscopy 135, 24–35 (2013).

https://discuss.cryosparc.com/t/tight-corrected-and-loose-gsfsc-curves/201/4

https://discuss.cryosparc.com/g/team
https://discuss.cryosparc.com/u/apunjani
https://discuss.cryosparc.com/g/team
https://discuss.cryosparc.com/t/tight-corrected-and-loose-gsfsc-curves/201/5


Mask maps
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volume_map volume_mask_refine volume_mask_fsc volume_mask_fsc_auto

Loose ? Tight ? Tight ?



Step 14: J15:Homogeneous Refinement [5.5 min with 1GPU]

(1) select [Outputs] tab

(2) Download “J*.volume_map” 



Step 14: Homogeneous Refinement [5.5 min with 1GPU]
[Tools]->[Volume Data]->[Volume Viewer]

Change : step = 1

Change contour Level

[File]->[Open…]

18031803



Step 14: Homogeneous Refinement [5.5 min with 1GPU]
[Tools]->[Volume Data]->[Volume Viewer]

Change : step = 1

Change contour Level

[File]->[Open…]

18031803
sharp sharp



Step 14: Homogeneous Refinement [5.5 min with 1GPU]
[Tools]->[Volume Data]->[Volume Viewer]

Change : step = 1

Change contour Level

[File]->[Open…]

18031803
mask mask
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