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今日の内容

i) 配列から相同な立体構造の検索

1．ホモロジー・モデリング法とは

iii) Modellerを用いたホモロジー・モデリング

ii) UCSF Chimeraによる配列と立体構造のアラインメント

i)タンパク質の結合分子の予測

ii)ヘテロ複合体構造の予測

iii)化合物‐蛋白質複合体構造の予測
付録：Modellerによる二量体のモデリングの手続き

2．ホモロジー・モデリング演習

3．複合体のホモロジーモデリング

4. HOMCOSサーバを用いた演習



ホモロジー・モデリング法とは



アミノ酸配列と立体構造の関係 (1)

HBB 4 :LTPEEKSAVTALWGKV--NVDEVGGEALGRLLVVYPWTQRFFESFGDLSTPDAVMGNPKVKAHGKKVLGAFSDGL:76 
* *  *  * * ****     * * *** *     * *   *  * ***      *   ** *****  *     

HBA 3 :LSPADKTNVKAAWGKVGAHAGEYGAEALERMFLSFPTTKTYFPHF-DLSH-----GSAQVKGHGKKVADALTNAV:71 

HBB 77 :AHLDNLKGTFATLSELHCDKLHVDPENFRLLGNVLVCVLAHHFGKEFTPPVQAAYQKVVAGVANALAHKY:146 
** *        ** **  ** *** ** **   *   ** *   **** * *   *  * *   *  **

HBA 72 :AHVDDMPNALSALSDLHAHKLRVDPVNFKLLSHCLLVTLAAHLPAEFTPAVHASLDKFLASVSTVLTSKY:141 

HBB_HUMAN (1bz1B)
hemoglobin beta chain, human

配列一致率:46 %
HEM HEM

配列が似ていれば
立体構造も似ている

標準的な配列比較法
(BLAST)

HBA_HUMAN (1bz1A)
hemoglobin alpha chain, human



アミノ酸配列と立体構造の関係 (2)

MYG_HUMAN (3rgkA)
hemoglobin beta chain, human

HBA_HUMAN (1bz1A)
hemoglobin alpha chain, human

MYG  1:MGLSDGEWQLVLNVWGKVEADIPGHGQEVLIRLFKGHPETLEKFDKFKHLKSEDEMKASEDLKKHGATVLTALGG:75 
* **      *   **** *     * * * * *   * *   *  *      *    *   * **  *  **  

HBA  1:MVLSPADKTNVKAAWGKVGAHAGEYGAEALERMFLSFPTTKTYFPHF------DLSHGSAQVKGHGKKVADALTN:69 

MYG 76:ILKKKGHHEAEIKPLAQSHATKHKIPVKYLEFISECIIQVLQSKHPGDFGADAQGAMNKALELFRKDMASNYK: 148 
*   ** *           * *    *    *  *         * *        * * 

HBA 70:AVAHVDDMPNALSALSDLHAHKLRVDPVNFKLLSHCLLVTLAAHLPAEFTPAVHASLDKFLASVSTVLTSKYR: 142 

HEM HEM

配列が似ていれば
立体構造も似ている

配列一致率:27 %

標準的な配列比較法
(BLAST)



アミノ酸配列と立体構造の関係 (3)
HBA_HUMAN (1bz1A)
hemoglobin alpha chain, human

GLB1_ANAIN (3g46A)
Globin-1, Anadara inaeqequivalivis (二枚貝)
配列一致率：17%

HMP_ECOLI (1gvhA)
Flavohemoprotein, hmp, 
Escherichia coli
(大腸菌) 配列一致率：17%

PHCA_ARTPT (1gh0A)
C-phycocyannin alpha chain, cpcA
Arthrospira platensis (シアノバクテリア、
藍藻、藍色細菌) 配列一致率:10%

プロフィール法
(PSI-BLAST)

立体構造比較
(MATRAS)

10%

17%

17%

FAD

HEM

HEM

CYC: phycocyanobilin
ヘムから鉄が抜け、開裂した分子

配列類似性がかなり低くても
立体構造が似ている場合がある
⇒立体構造は配列よりも進化的によく保存



立
体
構
造
の
変
化

アミノ酸配列の変化と立体構造の変化の相関(グロビン族）

立体構造の変化はアミノ酸配列の変化と相関
配列が３０％以上一致していれば、RMSDは２Å以下

アミノ酸配列の類似度※アラインメントは立体構造比較
プログラム(MATRAS)で計算



アミノ酸配列と立体構造の関係のまとめ

・アミノ酸配列が有意に似ていれば、多くの場合
立体構造も似ている

⇒相同（進化的な起源を同じにする）タンパク質の立体
構造は、おおむね似た形をしている

⇒「立体構造はアミノ酸配列より進化的によく保存する」

⇒タンパク質の機能は、その立体構造をベースとするの
で、大きく構造を変化させるアミノ酸置換は進化の過程
で淘汰されてしまうから？

・相同なタンパク質であっても、配列類似性が低く
なるほど、立体構造のずれは多くなる。

相同性（ホモロジー; homology）: 進化的に共有祖先をもつことに由来すると考えられる類似性。



立体構造予測法の二つのアプローチ
名称 ホモロジー・モデリング法

比較モデリング法
鋳型ベース予測法

非経験的予測法
Ab initio予測法
De novo予測法

手法の概要 鋳型立体構造にできるだけ似た形
で、立体構造を予測

鋳型構造を用いずに、物理化学的な
原理（分子シミュレーションの技法）
に基づいて立体構造を予測

鋳型立体構造 必要 不要

一般性 低い 高い

計算量 少ない 多い

予測精度 似た鋳型があれば高い 高い精度を得るには大きな
計算量が必要

単体の立体構造予測 MODELLER, SWISS‐MODEL,
RosettaCM, 3Dzigzaw

ROSETTA, EVfold,…

蛋白質複合体予測 MODELLER, HOMCOS ZDOCK, HADDOCK,…

低分子―タンパク質
複合体予測

MODELLER, HOMCOS, 
fkcombu

DOCK, AutoDock, sievgene, 
Glide,…



テンプレート
構造

ステップ１：フォールド認識 ステップ２：モデリング

予測対象配列 （クエリ配列）

立体構造データベース
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LNVANGKSVIGPALLEEVWFS-RD
* * * ** **  * * **  **

MNIADG-SVVGPTALQEAWFTQRD

鋳型（テンプレート）構造とそのアラインメント

ホモロジー・モデリングによる３次構造予測
原理 : 立体構造はアミノ酸配列より進化的に保存する.

立体構造データベースの中から、クエリ配列に

最も適合する「鋳型構造（テンプレート構造）」を探す

鋳型（テンプレート）構造に従って全原子を構築
（１）側鎖原子の構築
（２）挿入ループ部を構築

BLAST,  プロフィール法, スレディング法…. MODELLER, SWISS-MODEL,
RosettaCM, 3Dzigzaw



相同なタンパク質の発見する方法(フォールド認識)

同一残基率30%以上

BLASTのE-value < 0.0001

PSI-BLASTのE-value < 0.0001

4030100
15 25 355

同一残基率(Sequence Identity)（％）

立体構造比較

1007050 60 80 9020

・BLASTでヒットしない場合でも、プロフィール法(PSI-BLAST, HMMer, HHsearch,
HHBlitsなど）では、ヒットする場合がある。

・配列類似度が低い場合、鋳型の相同タンパク質が見つかっても、予測精度には限界
があるので、使用目的には注意が必要。

・立体構造比較は、複合体のホモロジー・モデリングのために役に立つことがある。

配列解析



モデリング
鋳型（テンプレート）構造を元にした全原子の構築

Sequence  ALIMSTKGFVS
Structure LLLM---GFIT

(1)ループの構築

(2)側鎖原子の構築

Sequence  AYVIND
Structure AFVVTD AFVVTD AYVIND

テンプレート モデル

テンプレート モデル

MODELLER, SWISS-MODEL, RosettaCM, 3Dzigzaw



MODELLERの手続き：空間拘束の充足
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Target  :-CD-FGHNIKL
Template:ACDEFGH-IK-
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1. 標的配列を鋳型構造に
アラインメントする

2. 空間的拘束(spatial constraint)
を抽出する

3. 空間的拘束を満たすような
構造を探す

・空間的拘束 = 相同な鋳型構造から得られる拘束 + 立体化学的な拘束

・空間的拘束は、CHARM22の力場と似た形式の目的関数（ポテンシャルエネルギー）に変換される

・構造探索は、1) 可変目的関数法+共役勾配法, 2)焼きなまし法+分子動力学法 で行う。

・ループの構築や側鎖の構築の手続きは、この「空間的拘束の充足」の手続きに含まれる。

B. Webb, A. Sali. Comparative Protein Structure Modeling Using Modeller. Current Protocols in Bioinformatics, 
John Wiley & Sons, Inc., 5.6.1-5.6.32, 2014.
A. Sali & T.L. Blundell. Comparative protein modelling by satisfaction of spatial restraints. J. Mol. Biol. 234, 779-
815, 1993.



鋳型：2yn1_A LGPCA Thioredoxin

鋳型とのSeqID=52.5%
RMSD(C)=1.08 Å

モデル結果の例: 予測対象 2trx_A Thioredoxin (Escherichia coli)

鋳型とのSeqID=25.3%
RMSD(C)=2.30 Å

鋳型：1fb0_A Thioredoxin M
(Spinacia oleracea (spinach))

鋳型：1x5e_A Thioredoxin
domain containing protein 
( Homo sapiens)

鋳型とのSeqID=86.5%
RMSD(C)=0.64 Å

RMSD(全重原子)=2.83 ÅRMSD(全重原子)=1.81 ÅRMSD(全重原子)=1.29 Å

赤：正解構造(2trx_A)
青：予測構造

アラインメント：BLAST, モデリング：MODELLER



モデルの精度とその使い方
鋳型との配列一致率
(Sequence Identity)

モデルの精度
CaのRMSD

使い方 ( Applications )

50 ~ 100 % 1.0 Å 触媒機構の研究
リガンドの設計・改変
高分子のドッキング
結合蛋白質の予測
仮想スクリーニング・低分子のドッキング

30 ~ 50   % 1.5 Å 抗体のエピトープの同定
Ｘ線結晶解析の分子置換
キメラ体の設計
より安定で結晶化容易な変異体の設計
部位特異的変異体の解釈
NMR構造の精密化
低解像度電子密度マップへのフィッティング

30 %以下 3.5 Å 疎な実験データからのモデリング
立体構造類似性からの機能推定
保存された表面残基のパッチの同定
３Ｄモチーフによる機能部位の発見

Baker, D., Sali, A. Science (2001),  294, 93‐96



UCSF ChimeraとModellerを用いた
ホモロジー・モデリング



配列から相同立体構造の取得
標的（予測対象）とするアミノ酸配列： UniProtの CALL5_HUMAN

CALL5_HUMAN: [Q0NZT1 ]: Calmodulin-like protein 5

VARIANT 58 58 S -> G 
(polymorphism confirmed at protein FT level;dbSNP:rs11546426).

VARIANT 74 74 K -> R 
(polymorphism confirmed at protein FT level; dbSNP:rs10904516). 

SQ SEQUENCE 146 AA; 15893 MW; 70746291268494CC CRC64; 
MAGELTPEEE AQYKKAFSAV DTDGNGTINA QELGAALKAT GKNLSEAQLR KLISEVDSDG 
DGEISFQEFL TAAKKARAGL EDLQVAFRAF DQDGDGHITV DELRRAMAGL GQPLPQEELD 
AMIREADVDQ DGRVNYEEFA RMLAQE 

※ちなみに、ヒトの有名なカルモジュリンは、CALM_HUMANで、CALL5とは50%ほどの
配列一致率。

二つの変異体がUniProtに記載されている



アミノ酸配列の取得と検索
1) Googleで”UniProt“と入力 2) UniProtのページのフォームに”CALL5_HUMAN“と入力

3) CALL5_HUMANのページ
４) メニューの[Format]から”FASTA(canonical)”を選ぶ

5)一文字表記のアミノ酸配列が表示される。
これをマウスで選択し、コピーする。



PDBjによる相同な立体構造（鋳型構造）の検索
1) Googleで”PDBj“と入力 2) PDBjのトップページから”Sequence Navigator”を選択

3) [Search by sequence]のタブを選び、
フォームに、UniProtのページでコピーし
たCALL5_HUMANの配列をペースト

4) 対PDBの
BLAST検索の結
果が表示される。
PDBコード“1ahr”
のA鎖が、
sequence identity 
52%でヒット。

→これを鋳型とする



Chimera：鋳型構造の読み込み
1) Chimeraを起動して、メニューから [File]→[Fetch by ID…]を選ぶ。

2)  [PDB]を選択、IDのフォームに”1ahr”と入力し、[Fetch]をクリック。

3)  左図のような構造が表示

されるはず。緑色の球はカル
シウムイオン。

4) メニューから[Favorites]→[Sequence]  を選ぶ。と以下の
Sequenceウィンドウが表示される。



Chimera：標的配列の読み込み
1) Sequenceウインドウのメニューから [Edit]→[Add Sequence…] を選ぶ

とAdd Sequenceのウィンドウが表示される。

2) Add Sequenceウィンドウから、[From UniProt]の
タブを選択し、UniProt name/IDのフォームに、
“ CALL5_HUMAN ”と入力し、[OK]をクリック。

3) 以下のような構造(1ahr)と配列(CALL5_HUMAN)
のアラインメントが表示される。

※逆の順に、最初にUniprotの標的配列を読み込み、次に鋳型の構造を読み込んで、
[Add Sequence]→[From Structure]で構造を指定することもできます。



Chimera:変異箇所の立体構造の確認
VARIANT 58 S -> G (polymorphism confirmed at protein FT level). 

MAGELTPEEE AQYKKAFSAV DTDGNGTINA QELGAALKAT GKNLSEAQLR KLISEVDSDG 
DGEISFQEFL TAAKKARAGL EDLQVAFRAF DQDGDGHITV DELRRAMAGL GQPLPQEELD 
AMIREADVDQ DGRVNYEEFA RMLAQE 

1) 58番目のS (VDSDG)を探し、それに対応する構造部位（この場合はA）をマウスで選択する。

2) 選択された状態で、
[Actions]→[Atoms/Bonds] →[Show] 
とすると、選択された構造部位がスティック
表示される。

SNPが報告されている 58番目のS (S->G)の立体構造上の位置を確認してみる。

※同様に74番目のK -> R 
の位置も確認してみる



Chimera:標的配列のCa2+結合部位の推定
鋳型立体構造(1ahr)のCa2+イオンの結合部位を求め、sequenceウィンドウで対応する標
的配列の部位を確認すればよい。

1) メニューから[Select]→[Residue]→[CA]を選択し、
Ca2+イオンを選択。

2) メニューから[Select]→[Zone…] を選択する。

3) Select Zone Parameterのウィンドウが表示される。
一番上のフォームの”5.0”を”4.0”に書き直して、[OK]
をクリックする。

4) 選択された状態で、 [Actions]→[Atoms/Bonds] 
→[Show] で、 Ca2+結合部位がスティック表示される。

5) 選択された状態で、 sequenceウィンドウを確認す
ると、 Ca2+結合部位が緑色で強調表示されている。



Modellerによるホモロジーモデリング(1)
1) sequenceウィンドウの [Structure]→[Modeller(homology)…] 
を選択

2) Modellerウィンドウの、Choose the targetを”CALL5_HUMAN”とし、
Choose at least one template：を1ahr(#1) chainAを選択する。

3) [Advanced Options]をクリックし、
[Number of output models](出力するモデ
ル構造の数)を１とし、

[Include non-water HETATM residues
from template](低分子化合物・イオンをモ
デルに含めるかどうか)をチェック☑する。



ローカルにModellerを起動するための注意
Location of Modeller executableを設定する必要があります。

C:¥Program Files¥Modeller9.19¥lib¥x86_64-w64¥mod9.19.exe

デフォルトでは間違った
場所に設定されている
かもしれません。

Windowsの場合の設定例

※バージョンやインストール場所によって詳細は異なります。各自の設定に合わせてください。

[Browse]をクリックして
フォルダを移動し、
Modellerの
実行ファイルを選択

Macintoshの場合の設定例

/usr/local/bin/mod9.19

[Browse]をクリックして
フォルダを移動し、
Modellerの
実行ファイルを選択



Web Serverを利用する場合
ローカルのModellerを起動できない場合、 Chimeraの開発グループが用意した
Web serverを利用することができます。

アカデミックライセンスの
ライセンスキー文字列を
入力する必要があります。

アカデミックの方が、ライセンス
キーを取得するには
http://salilab.org/modellerにア
クセスし、[Registration]から、

ユーザー情報を入力してくださ
い。しばらくすると、ライセンス
キーの文字列が電子メールで
送付されます。

※Web Serviceを利用した場合も、ローカルに起動した場合も以後の手続きは同じです。



Modellerによるホモロジーモデリング (2)
4) Modellerウィンドウの下の[OK]をクリックすると、計算が開始する。

計算終了までは１分～数分かかる。計算進行状況は、画面左下に表示される。

5) 計算が終了すると、鋳型構造とモデル構造が表示される。

6) [Favorites]→[Model Panel] を選択

Model Panelウィンドウの[Shown]の☑のオン・オフで、オブジェクトの表示・非表示を選択可能。

鋳型構造(1ahr) モデル構造(1ahr)

※Modellerでは水素原子は生成されません。



Modellerによるホモロジーモデリング (3)
7) [File]→[Save PDB…] を選択すると、

8) 適当なフォルダとファイル名
（”CALL5_HUMAN.pdb”）
を入力

9)Save models:
では、保存したモデル
（”CALL5_HUMAN model 1 (#1.1)”）
を選択

10) [Save]をクリック

最後に、モデリングした構造だけを、PDB形式のファイルに保存する



CDK3_HUMANのモデリング例
鋳型構造 1oitA
(CDK2_HUMAN)

点線は立体構造が
決まっていない部分

鋳型と標的配列のアラインメント

赤線で囲まれた部分は、立体構造
が決まっていない部分



CDK3_HUMANのモデリング例
５つの候補モデル構造
を出力させた場合

鋳型構造とアライメントされない
部分（ループ部、挿入部）は、

候補構造ごとにかなり異なった
構造になる

⇒ 鋳型とのアラインメントされ
ていない部分の予測構造は、一
般に一意に構造を決めるのが難
しく、信頼性が低い場合が多い。



ホモロジー・モデリング法の使い方の留意点

• 鋳型構造の選択とアラインメントが予測精度をほぼ決定

• 鋳型構造とアラインメントされていない部分（ループ部・
挿入部）の構造を決めるのは一般に困難

・同じような鋳型構造が複数ある場合、解像度・結合リガンドなどを考慮して選択する。

・配列モチーフなどが一致するようにアライメントの手修正が必要な場合もある。

・特にアミノ酸長が長くなると、挿入部の信頼性は著しく低くなる。

・どうしても、ループ部の構造を使う必要がある場合、複数の構造を出力させて、
候補構造集団として、取り扱ったほうがよい。

・特に、配列類似性が低い鋳型構造を使う場合、BLASTよりも、PSI-BLAST, HMMerなど
のプロフィール法のほうが、正確なアラインメントを与える。

・鋳型構造の選択・アライメントの不具合は、「モデリング」の過程では修正されない。

※鋳型構造の検討にはHOMCOSの「タンパク質に対する結合分子の検索」が役立つ。



コマンドラインでのModellerの使用法
>P1;query
sequence:query:2: :144: : : : :
AGELTPEEEAQYKKAFSAVDTDGNGTINAQELGAALKATGKNLSEAQLRKLISEVDSDGD
GEISFQEFLTA-AKKARAGLEDLQVAFRAFDQDGDGHITVDELRRAMAGLGQPLPQEELD
AMIREADVDQDGRVNYEEFARMLA--
*
>P1;1ahr
structureX:1ahr:1:A:148:A: : : :
ADQLTEEQIAEFKEAFSLFDKDGDGTITTKELGTVMRSLGQNPTEAELQDMINEVDADGN
GTIDFPEFLTMMARKMKDSEEEIREAFRVFDKDGNGFISAAELRHVMTNLGEKLTDEEVD
EMIREADIDGDGQVNYEEFVTMMTSK
*

from modeller import *
from modeller.automodel import *
log.verbose() 
env = environ()
env.io.atom_files_directory = ['.', '../atom_files']
env.io.hetatm = True
a = automodel(env,

alnfile  = 'alignment.ali', 
knowns   = '1ahr',  
sequence = 'query')

a.starting_model= 1 
a.ending_model  = 1  
a.make()

(1)アラインメントファイル
(alignment.ali)

(2) 鋳型のPDBファイル
(1ahr.pdb)

(3) スクリプトファイル
(model.py)

の三つのファイルを用意し、
コマンドラインで、
mod9.19 model.py

というコマンドを実行すれば
よい。

alignment.aliの内容

model.pyの内容

⇒alignment.aliファイル
をエディタで修正すれば、

アラインメントを手直しする
ことができる。

⇒HOMCOSサーバで
これらのファイルを生成
することも可能



UCSF Chimeraだけで実行できる解析

・リガンド分子と近接している残基の同定 [Select]→[Zone…]
・指定した原子間の距離の計測 [Tools]→[Structure Analysis]→[Distance]
・静電ポテンシャルによる分子表面の色付け

[Tools]→[Surface/BindingAnalysys]→[CoulombicSurfaceColoring]
・アミノ酸配列と立体構造とのアラインメント [Tools]→[Sequence]
・進化的保存が高い部位の立体構造上の位置の観察 [Tools]→[Sequence]
・１アミノ酸置換構造のモデリング [Tools]→[Structure Editing]→[Rotamer]
・相同な二つの立体構造の比較 [Tools]→[Structure Comparison]→[MatchMaker]
・モーフィングアニメーション

[Tools]→[Structure Comparison]→[MorphConfomation]

・水素原子の付加 [Tools]→[Structure Editing]→[AddH]

・部分電荷の付加 [Tools]→[Structure Editing]→[Add Charge]
・低分子ドッキングプログラム Auto Dock Vina の実行

[Surface/Binding Analysis]→[AutoDock Vina]
・ドッキング候補ポーズの解析 [Surface/Binding Analysis]→[ViewDock]

「見てわかる構造生命科学」に記載されている機能

それ以外の機能

・ペプチド・化合物・核酸の構造構築 [Tools]→[Structure Editing]→[Build Structure]



UCSF Chimeraの実行コマンド一覧

書式 例 意味

display と ~display 原子の表示と非表示

ribbon と ~ribbon リボンモデルの表示と非表示

surface と ~surface 分子表面の表示と非表示

repr [表示法] repr sphere 原子を空間充填モデルで

[表示法]は、球：sphere、線：wire、スティック：stick、ボール&スティック：bsが使える。

color [色] color blue 青色にする

color byelement 元素ごとに色分けする

rainbow N末からC末へ虹色に

rainbow chain 鎖ごとに虹色に

set bg_color [色] set bg_color white 背景を白に

turn [xyz] [回転角（°）] turn y 180 Y軸のまわりに180°回転

reset 分子を元の向きに戻す

[Favorites]→[Command Line]で
画面下部にCommand:という
コマンドを打ち込む窓が表示される。

コマンドを打ち込むことで、より細やかな設定が可能になる。



UCSF Chimeraの選択コマンド一覧

書式 例 意味
[実行] :.[鎖] color red :.A A鎖を赤に

[実行] :[残基名] color red :CYS システインを赤に

[実行] @[原子名] color red @CB Cb原子を赤に

[実行] :[残基名].[鎖]@[原
子名]

color red :CYS.A@CB A鎖のシステインのCb原子を赤
に

[実行] :[番号] color red :104 104番目を赤に

[実行] :[番号],[番号] color red :104,212 104番目と212番目を赤に

[実行] :[番号]-[番号] color red :104-212 104～212番目を赤に

[実行] :[番号]-[番号].[鎖] color red :104-212.A A鎖の104～212番目を赤に

[実行] [条件] za<[距離] color red :ATP za<5 ATPから5Å未満の原子を赤に

[実行] [条件] zr<[距離] color red :ATP zr<5 ATPから5Å未満の残基を赤に

[実行] [条件] && [条件] color red :.A && :104 A鎖の104番目を赤に

[実行] [条件] || [条件] color red :SER || :THR セリンかスレオニンを赤に

[実行] protein color red protein タンパク質を赤に

[実行] nucleic acid color red nucleic acid 核酸を赤に

[実行] ligand color red ligand リガンド分子を赤に



UCSF Chimeraの操作法などが
載っている本

見てわかる 構造生命科学 ―生命科学
研究へのタンパク質構造の利用―
中村春木 編 化学同人 税抜5000円
RasMol,  UCSF Chimera, PyMOLの
使い方を解説



HOMCOSサーバを用いた
複合体の検索とモデリング



Cyclin-dependent protein kinase (CDK2)

ADP
Substrate Peptide
PKTPKKAKKL

Cyclin A2

複合体立体構造は
単量体構造より機能情報が豊富

複合体立体構造から以下のことがわかる
(1)他の分子との結合部位

→変異体の解釈・設計
→ 阻害剤の設計・改変

(2)結合・反応のメカニズムの理解 3D Complex of 
CDK2＋ADP
＋Cyclin A2 
+ Peptide
(PDBcode:3qhw)

38



鋳型ベースのモデリング:Template‐based Modeling

既知の立体構造
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予測立体構造

タンパク質－タンパク質
複合体
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化合物－タンパク質
複合体
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タンパク質単量体

TGWVEIEINL..

TGWVEIEINL..

QLVVKTFAFT..

IVAWGKTDLQAE..

既知の立体構造 予測立体構造

既知の立体構造 予測立体構造

複合体のホモロジー・モデリング
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HOMCOS :複合体立体構造の検索・ホモロジーモデリングのサーバ

サービス 入力１ 入力２

PDB内の

結合分子
の検索

タンパク質に対する
結合分子の検索

アミノ酸
配列

化合物に対する
結合分子の検索

化合物
構造

複合体

立体構造
の
ホモロジー
モデリング

ホモ多量体モデル アミノ酸
配列

ヘテロ多量体モデル アミノ酸
配列A

アミノ酸
配列B

化合物ータンパク質
複合体のモデル

アミノ酸
配列

化合物
構造

・PDB内の複合体の立体構造データを検索し、それを鋳型にモデリングする

・配列相同性検索はBLAST、化学構造類似性検索はKCOMBUを使用

MYB

HRX
Crebbp

MYB

MRE-1

MRE-1

http://homcos.pdbj.org
“HOMCOS”でグーグル検索

アミノ酸配列２本を入力、それぞれ、PDBに
対するBLASTを実行

ヘテロ多量体のモデリング

タンパク質に対する結合分子検索

化合物－タンパク質複合体のモデル
アミノ酸配列と化合物構造を入力、アミノ酸配列はBLASTで、
化学構造はKCOMBU   でPDBに対して検索

BLAST BLAST 

BLAST KCOMBU 

鋳型構造

鋳型構造

予測構造 予測構造

VaProSからの検索では、 3D Interactionに相当
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テンプレート
構造

ステップ１：フォールド認識 ステップ２：モデリング

予測対象配列

立体構造データベース

LNVANGKSVIGPALLEEVWGSRD

M

N

I

A
D

G
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G
A L

Q
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A W

F
T

QD

PT

R

L

N

V

A
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G

S
V

I

G
L L

E
E

V W

F
S

QD

PA

R K

LNVANGKSVIGPALLEEVWFS-RD
* * * ** **  * * **  **

MNIADG-SVVGPTALQEAWFTQRD

テンプレート構造とそのアライメント

ホモロジー・モデリングによる３次構造予測

立体構造データベースの中から、クエリ配列に

最も適合する構造（テンプレート構造）を探す

テンプレート構造に従って全原子を構築
（１）側鎖原子の構築
（２）挿入ループ部を構築

HOMCOSは
BLASTを採用

HOMCOS が提供するサービス

HOMCOSは、
（１）簡易モデルと（２）MODELLERの入力ファイル
のみを提供

41



HOMCOSを用いた
蛋白質の結合分子の予測
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タンパク質に対する結合分子の検索

>1vwg_A

>1jsu_B

2g9xA
1w98A
1fq1B
:

問い合わせ配列

問い合わせ化合物

1vwg_1 A1 B1
2g9x_1 A1 B1
:

KCOMBU検索

BLAST検索

TGWVEIEINL…

コンタクトしている分子の表

SHL
C39
GBC
:

類似した化合物のリスト

相同なタンパク質のリスト

SHL

GBC

C39

1vwg_1 A1 B1
2g9x_1 A1 B1
:

コンタクトしている分子の表

問い合わせ配列とコンタクトする
分子の予測リスト

問い合わせ化合物とコンタクトする
分子の予測リスト

化合物に対する結合タンパク質の検索

PDBに登録された
アミノ酸配列の
データベース

PDBに登録された
化合物の
データベース
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CDK3を題材をした結合分子予測

1) Googleで”HOMCOS“と入力 2) 「タンパク質に対する検索」を選ぶ

3) UniProtIDのフォームに
“CDK3_HUMAN”と入力して、
[SEARCH]をクリックする。

問い合わせ蛋白質の配列は以下の４通りで入力可
(i) PDB_ID+鎖 (ii) PDBファイルのアップロード
(iii) UniProt ID  (iv) アミノ酸配列

CDK3_HUMAN  (Cyclin-dependent  kinase 3)
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「タンパク質に対する検索」結果のトップ画面(CDK3)
・単量体、複合体構造は、デフォルトでは代表構
造だけがバー表示されている。アライメント領域・
相互作用部位によって代表を決めている。

・相同性のしきい値は、デフォルトではE-value<0.001
だけで、同一残基率は0%に設定。よりしきい値を上げ
れば（30%,40%,…,95%）、候補構造は減るが、予測
の信頼性は向上。・全ての相同な立体構造を表示する場合は、

[Full Bars] をクリックする。

のアイコンをクリックすると単量体の立体構造モデルが表示される
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単量体立体構造の表示(CDK3)
Sequence-replaced 3D model（簡易ホモロジーモデル構造）：

鋳型構造と座標は同じ。残基名と残基番号を標的配列と入れ替え
てある。側鎖原子や挿入残基は正しくモデリングされていない。

クエリ(CDK3_HUMAN)
と鋳型(1pf8_A_1）との
アラインメント

簡易ホモロジーモデル構造の
ダウンロード

鋳型構造の
ダウンロード

をクリックすると、
生物学的単位に含まれる
全ての分子が表示される

をクリックすると
Modellerの入力ファイルを
ダウンロード可能。
Modellerをインストールす
れば、全原子のモデルが構
築可能

CDK3
（鋳型はCDK2）

メニューから

表示される構造
の種類を選ぶこ
とができる

デフォルトではHTML5(Jsmol)による分子の表示。
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マウスの使い方
表示法 UCSF Chimera JSmol
分子の
回転

左ボタンで画面をドラッグ 左ボタンで画面をドラッグ

分子の
並進

ホイール(中ボタン)で画面をド
ラッグ

Ctrlキーを押しながら、右ボタン
で画面をドラッグ

ズームイ
ン・アウト

(1)ホイールを回す
(2)右ボタンをドラッグ

(1)ホイールを回す
(2)Shiftキーを押しながら、左ボ
タンで画面をドラッグ
(3)右ボタンと左ボタンを同時に
押して、画面をドラッグ

マウスに
よる残基
名・原子名
の確認

画面上で、カーソルを原子の上
に置き、しばらく待つと、ポップ
アップでラベルが表示される

画面上で、カーソルを原子の上
に置き、しばらく待つと、ポップ
アップでラベルが表示される
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Contact Barのヘテロ複合体の画面(CDK3)

相互作用部位

標的分子と鋳型の同一残基率(%)
値が高いほど予測の信頼性が高い。
最初の数字は、相互作用面の同一残基率、
二番目の数字は全体の同一残基率

コンタクトしている別の
タンパク質の分子名

のアイコンをクリックすると
ヘテロ複合体の
立体構造モデルが
表示される
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ヘテロ複合体立体構造の表示(CDK3)

CDK3
（鋳型はCDK2）

Cyclin A2

予測接触残基
標的配列(CDK3)の残基番号、残基名．カッコ内は鋳型のアミノ酸

接触残基が’b’
の文字で示さ
れている。

複合体のSequence-replaced 
model、鋳型構造のダウンロー
ド、Modellerの入力ファイルの
ダウンロードも同様に可能

CDK3

Cyclin A2

生物学的単位内の全分子を表示
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生物学的単位内の全分子を表示した場合

CDK3
（鋳型はCDK2）

Cyclin A2

CDK3

Cyclin A2

低分子化合物
(T7Z)

特にDNA
二重鎖

を扱うとき
に

が重要。

50
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Contact Barの化合物複合体の画面(CDK3)

相互作用部位

4QE, 4SPなどはPDBの３文字表記の分子名

コンタクトしている
化合物の分子名

のアイコンをクリックすると
化合物－タンパク質複合体の
立体構造モデルが
表示される

標的分子と鋳型の同一残基率(%)
値が高いほど予測の信頼性が高い。
最初の数字は、相互作用面の同一残基率、
二番目の数字は全体の同一残基率
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化合物－タンパク質複合体(CDK3)

化合物名。
３文字表記は4QE

予測接触残基
標的配列(CDK3)の
残基番号、残基名

接触残基が’b’の文字で示されている。

CDK3
（鋳型はCDK2）

複合体のSequence-replaced 
model、鋳型構造のダウンロー
ド、Modellerの入力ファイルの
ダウンロードも同様に可能
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Site Table
コンタクトバー表示の画面上のこのアイコンをクリック

UniProtのアノテーション
(Feature Table)

結合分子のサマリー

相同配列群のアミノ酸頻
度。頻度順にソート。出現
したアミノ酸だけ表示

二次構造
(H:αへリックス、E:βシート) 溶媒露出度(%)

をクリックすると特定のサイト
のまとめのページが表示される

(1) 埋もれている部位（溶媒露出度accが
小さい部位）に変異が入ると、天然構造が
不安定になり、機能を失活しやすい。

(2) 相同タンパク質群で観察されるアミノ酸の割合（observed aa）が大

きい（よく観察される）アミノ酸に変異した場合、機能への影響は小さい。
逆に、稀にしか観察されないアミノ酸に変異した場合は、機能を失いや
すい。SIFT scoreなど多くのプログラムがこの原理に基づく。
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3番目の部位のまとめ(CDK3)

相同配列群のアミノ酸頻度。
頻度順にソート。出現した
アミノ酸だけ表示

これらのPDBのIDをクリックする
と、この部位（3番目の部位）を

結合サイトとする複合体立体構
造のモデルが表示される。
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３番目の部位がタンパク質間相互作用部位
となる例(CDK3)

Cyclin A2
３番目のMet
(鋳型ではAsn)

CDK3
(鋳型は
CDK2)
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ARSA_HUMANの場合のSite Tableの画面

UniProtのアノテーション
(Feature Table)

結合分子の
サマリー

相同配列群のアミ
ノ酸頻度。頻度順
にソート。出現した
アミノ酸だけ表示

溶媒
露出
度(%)

UniProtの変異体に
関する情報(VARIANT)

をクリックすると特定のサイトのまとめのページが表示される

(1) 埋もれている部位（溶媒露出度accが
小さい部位）に変異が入ると、天然構造が
不安定になり、機能を失活しやすい。

(2) 相同タンパク質群で観察されるアミノ酸の割合（observed aa）が大

きい（よく観察される）アミノ酸に変異した場合、機能への影響は小さい。
逆に、稀にしか観察されないアミノ酸に変異した場合は、機能を失いや
すい。SIFT scoreなど多くのプログラムがこの原理に基づく。

ARSA_HUMAN(Arylsulfatase A)
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29番目の部位のまとめ(ARSA)

D→Nの変異は、
Leukodystrophy 
metachromatic(MLD)
[リソソーム病(異染性
白質ジストロフィー)]と
いう病気と関連がある。

カルシウムイオン
(Ca2+)との複合体構
造が予測されている。

29番目のDの進化的保存は極めてよい(100%)
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29番目の部位に注目した
Ca2+イオンータンパク質複合体の予測結合構造

Ca2+

29番目の部位のD→Nの変異によって
Ca2+イオンとの結合に影響が及ぶ可能性

Ca2+

29番目の
Asp
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HOMCOSを用いた
ヘテロ蛋白質複合体の予測
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ヘテロ蛋白質複合体のモデリング

>1vwg_A

>1vwg_B

>2g9x_A

1vwgA
2g9xA
8atcA
1fq5A
:

1vwg_1 A1 B1
2g9x_1 A1 B1
1jsu_1 A1 B1
8atc_2 A1 B1
2fi5_1 E2 I1
:

BLAST 検索

BLAST検索
相同な複合体の一つを
鋳型として取り出す

鋳型構造：1vwg_1  A1 B1
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TGWVEIEINL...

QLVVKTFAFT...

結合している
分子の表

1vwgB
2g9xB
2fi5I
2eufA
:

配列Bと相同な
タンパク質のリスト

配列Aと相同な
タンパク質のリスト

Template-based Model
(Sequence-replaced model)

予測モデル構造
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単量体の
重ね合わせ

Template-based docking

予測モデル構造

問い合わせタンパク質B

問い合わせタンパク質A
配列

単量体
構造

or

配列

単量体
構造

or

orPDB内のアミノ酸配列
のデータベース
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ヘテロ多量体のモデリング(2本の配列から）

1) Googleで”HOMCOS“と入力 2) 「ヘテロ多量体のモデル」を選ぶ

CDK5_HUMAN： Cyclin-dependent proten kinase 5
CCNB1_HUMAN ：G2/mitotic-specific cyclin B1 

3) タンパク質AのUNIPROT_IDにCDK5_HUMANを
タンパク質BのUNIPROT_IDにCCNB1_HUMANを入力

問い合わせ蛋白質の配列は以下の４通りで入力可
(i) PDB_ID+鎖 (ii) PDBファイルのアップロード
(iii) UniProt ID  (iv) アミノ酸配列 61



ヘテロ多量体のモデリング（２本の配列から）

CDK5_HUMAN CCNB1_HUMAN

複合体のsequence-replaced 3D model

sequence-replaced model
template 3D structure
の二つを、表示・ダウンロード可能

配列Aと配列Bに
ついて、対PDBの
BLAST 検索が
実行される
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HOMCOSを用いた
化合物－蛋白質複合体の予測
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化合物ータンパク質複合体のモデリング

>1vwg_A

2g9xA
1jsuA
1fq5A
8atcA
:

PDB内のアミノ酸配列
のデータベース

2g9x A1 B1(SHL)
1jsu A1 B1(C39)
8atc A1 B1(PLP)
2fi5 E2 I2(ATP)
:

KCOMBU 検索

BLAST検索 鋳型となる
複合体構造の選択

結合している
分子の表

SHL
C39
GBC
:

問い合わせ化合物と
類似した化合物のリスト

問い合わせ配列
と相同なタンパク質のリスト

PDB内の化合物の
データベース
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※問い合わせ化合物はfkcombuを用い
フレキシブルに鋳型化合物に重ね合わせる

SHL

GBCC39

SHL

TVAWGKTDLQL…

鋳型：2g9x_A1 B1
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(Sequence-replaced model)

予測モデル構造

Template-based docking
予測モデル構造

>1vwg_B

>2g9x_A

配列の
置き換え

単量体の
重ね合わせor
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化合物タンパク質複合体モデリング
のページ

2) 「化合物タンパク質複合体のモデル」を選ぶ

3) PROTEINのUNIPROT_IDにはCDK3_HUMANを
COMPOUNDのPDB three letter ligand codeにはIREを入力

Iressa/Gefitinib (IRE)

1) Googleで”HOMCOS“と入力
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化合物ータンパク質複合体のモデリング

アミノ酸配列対PDBのBLAST 検索、
化合物 対PDBのKCOMBU検索
が実行される

標的化合物(IRE) 鋳型化合物(DTQ)

複合体のモデル構造が表示される

鋳型化合物(DTQ)

標的化合物(IRE)
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鋳型構造が全く見つからない場合は？

１．剛体ドッキングプログラムを試す。
高分子なら、ZDOCK, HADDOCK、低分子なら、DOCK, AutoDock 
vina, sievgene, GLIDE などがよく使われる。もちろん、単体の立体構造
が入手できる場合に限る。
⇒ 予測精度の限界を留意。結合部位などの実験情報をできるだけ
考慮したほうがよい。

２．分子動力学法などの高度なサンプリング法。
結合に伴って大きな構造変化がある場合は、分子動力学法などの分子
変形を伴うサンプリング法が必須なはず。
⇒ 計算量が膨大。専門家の助言を求めたほうがよい。

３．手作業で組み立てる
⇒ 実験情報がある程度あるなら、全く不可能でもない。

USCF Chimeraの[Favorites]→[Model Panels]でモデルパネルを立ち上げ、
[A]の☑をオン・オフしながら、分子の姿勢を変えていく。
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結合の強さの予測について

2．鋳型ベースで複合体予測ができても、本当に結合する
保証はない

・相同な複合体の鋳型構造があっても、相互作用するとは限らない。
・特にキナーゼ、GPCRなど多遺伝子族では、その特異性の予測は困難
・「もし結合するとしたら、どのように結合するか」の予測と考えるべき。
・相互作用に重要そうなアミノ酸の保存の確認まではできる

1．結合の強さの予測は、結合構造の予測より困難
・物理化学な手法による強さの予測は、正しい結合立体構造が必要。
結合構造に誤りがあると強さは正確に予測できない。
・生体分子間の相互作用は一般に弱く、１アミノ酸置換でも結合定数が
変わる可能性。精密な見積もりが要求される。
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付録：Modellerによる二量体の
モデリングの手続き
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Modellerによる二量体のモデリング [1]

（１）モデル３Ｄ構造のウィンドウで をクリックする

HOMCOSのヘテロ多量体モデリングで、CDK5_HUMANとCCNB1_HUMANを入力し、適当な鋳型構造(1h27)を選んで、以下のモデル
３Ｄ構造のウィンドウが表示されたとする。

（２）Modellerのスクリプトのページが表示される。

（３）スクリプトファイル (model_complex.py)、 アラインメントファイル(alignment_complex.ali),
鋳型構造のファイル(1h27.pdb)の三つを自分のパソコンにダウンロードする。

今回は、Windowsでは、 C:¥Users¥visitor¥Downloads というディレクトリに、
Macでは、 /Users/guest/Downloads というディレクトリに保存する。
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Modellerによる二量体のモデリング(Win10)[2]

(4)スタート画面の矢印をクリッ

クすると、インストールされたプ
ログラムの一覧が表示される。

(5)アルファベットのMにある、
“Modeller 9.19”というフォルダ
内にある”Modeller”というコマ

ンドプロンプトのアイコンをクリ
ック

(6)このようなコマンドプロンプト
のウィンドウが表示される。

(7) コマンドのウィンドウ内で
cd [ディレクトリ名]
と入力し、「モデリング用ディレクトリ」

（前頁で三つのファイルをコピーしたデ
ィレクトリ）に移動する。

今回は、cd C:¥Users¥visitor¥Downloadsと入力する。
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(8)コマンドdirを入力し、現在のディレクトリ内の

ファイルの一覧を表示。ダウンロードした三つの
ファイルがあることを確認。

Modellerによる二量体のモデリング(Win10)[3]

(9) コマンドmod9.19 [スクリプトファイル]
を入力し、Modellerを実行する。今回は、
mod9.19 model_complex.py
と入力する。この後、計算終了までには
１分～数分程度の時間がかかる。

(10)計算終了後、再びコマンドdirを入力すると、出力ファイルの一覧
を表示。このうち、query_complex.B99990001.pdbが予測構造

のＰＤＢファイル。このファイルをChimeraなどで開き、構造を確認。
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Modellerによる二量体のモデリング(Mac)[2]
(4)Finderから、
[移動]→[ユーティリティ]を選び
[ターミナル]を起動する。

(5)ターミナルのウィンドウ内で
cd [ディレクトリ名] と入力し、

「モデリング用ディレクトリ」（前頁で三つのファイルをコピーしたディレクトリ）に移動する。

今回は、cd /Users/guest/Downloadsと入力する。
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(6)コマンドlsを入力すると、現在のディレクトリ

にあるファイルの一覧を表示。ダウンロードし
た三つのファイルがあることを確認。

Modellerによる二量体のモデリング(Mac)[3]

(7) コマンドmod9.16 [スクリプトファイル]
を入力し、Modellerを実行する。今回は、
mod9.16 model_complex.py
と入力する。この後、計算終了までには
１分～数分程度の時間がかかる。

(8)計算終了後、再びコマンドlsを入力すると、

出力ファイルの一覧を表示。このうち、
query_complex.B99990001.pdbが予測

構造のＰＤＢファイル。このファイルをChimera
などで開き、構造を確認。 74


