
UCSF ChimeraとModellerを用いた
ホモロジー・モデリングと

HOMCOSサーバによる複合体立体
構造の検索・モデリング

川端 猛 （大阪大学・蛋白質研究所・特任研究員）

２０１５年６月１３日（土）
科学技術振興機構 東京本部別館 ２階セミナー室

PDBjing&創薬等情報拠点講習会
見てわかるタンパク質ー生命科学のための立体構造データの利用法

kawabata@protein.osaka-u.ac.jp

1



創薬等支援技術基盤プラットフォーム

生産領域：タンパク質試料の調整
解析領域：タンパク質構造解析

バイオインフォマティクス領域：構
造予測等の計算化学

ライブラリー・スクリーニング領域：
化合物ライブラリーの提供スク
リーニング機器の共用
合成領域：ヒット化合物の最適化

情報領域：データベース、
解析ツールの提供

プラットフォームをご利用希望の方は各拠点情報のページから詳しい支援メニューをご覧になり、ご
利用を希望する拠点の問い合わせ窓口または総合窓口（全般的なお問い合わせ）からお問い合わ
せください。また、お申し込みは各拠点情報のページにあるお申し込みフォームからご登録ください。

情報拠点： 生物学者のニーズを的確に捉えた 情報解析ツールの開発がミッション

アンケートに、ご要望・ご批判をたくさん書いていただけるとありがたいです

立体構造を用いた情報解析（モデリング、ドッキング等）の個別相談も受け付けています。



今日の内容

５．HOMCOSを用いたタンパク質の結合分子の予測

６．HOMCOSを用いたヘテロ複合体構造の予測

７．HOMCOSを用いた化合物―蛋白質複合体構造の予測

UCSF ChimeraとModellerを用いた演習

ＨＯＭＣＯＳを用いた演習

２．配列から相同な立体構造の検索

３． UCSF Chimeraによる配列と立体構造のアラインメント

４．Modellerを用いたホモロジー・モデリング

１．ホモロジー・モデリング法とは



立体構造予測法の二つのアプローチ
名称 ホモロジー・モデリング法

比較モデリング法
鋳型ベース予測法

非経験的方法
Ab initio予測法
De novo予測法

手法の概要 鋳型立体構造にできるだけ似た形
で、立体構造を予測

鋳型構造を用いずに、物理化学的な
原理（分子シミュレーションの技法）
に基づいて立体構造を予測

鋳型立体構造 必要 不要

一般性 低い 高い

計算量 少ない 多い

予測精度 似た鋳型があれば高い 高い精度を得るには大きな
計算量が必要

単体の立体構造予測 MODELLER, SWISS‐MODEL ROSETTA, EVfold,…

蛋白質複合体予測 MODELLER, HOMCOS ZDOCK, HADDOCK,…

低分子―タンパク質
複合体予測

MODELLER, HOMCOS, 
fkcombu

DOCK, AutoDock, sievgene, 
Glide,…



テンプレート
構造

ステップ１：フォールド認識 ステップ２：モデリング

予測対象配列 （クエリ配列）

立体構造データベース
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MNIADG-SVVGPTALQEAWFTQRD

鋳型（テンプレート）構造とそのアラインメント

ホモロジー・モデリングによる３次構造予測

原理 : 立体構造はアミノ酸配列より保存しやすい.

立体構造データベースの中から、クエリ配列に

最も適合する「鋳型構造（テンプレート構造）」を探す

鋳型（テンプレート）構造に従って全原子を構築
（１）側鎖原子の構築
（２）挿入ループ部を構築

BLAST,  プロフィール法, スレディング法…. MODELLER, FAMS, ….



モデリング
鋳型（テンプレート）構造を元にした全原子の構築

(MODELLER)

Sequence  ALIMSTKGFVS
Structure LLLM---GFIT

(1)ループの構築

(2)側鎖原子の構築

Sequence  AYVIND
Structure AFVVTD AFVVTD AYVIND

テンプレート モデル

テンプレート モデル

MODELLER :http://www.salilab.org/modeller/modeller.html



エネルギー最小化計算による
ホモロジーモデリング

MODELLER (http://www.salilab.org/modeller/) の場合

通常の分子シミュレーションのポテンシャル関数に、
テンプレート構造の距離拘束のエネルギー関数を加えて
同時にエネルギー最小化計算を行う



リガンドの設計

高分子のドッキング

低分子のドッキング

部位特異的置換のサポート

保存している表面残基の発見

反応メカニズムの理解

[分子置換法による精密化]

[NMRの精密化]

SeqID = 50 %

SeqID = 30 %

Ab initio

[電顕等の粗い電子密度へのフィット]

SeqID = 100 %モデリングした構造の精度と用途

Baker, D., Sali, A. Science (2001),  294, 93-96



UCSF ChimeraとModellerを用いた
ホモロジー・モデリング



配列から相同立体構造の取得
標的（予測対象）とするアミノ酸配列： UniProtの CALL5_HUMAN

CALL5_HUMAN: Calmodulin-like protein 5

VARIANT 58 58 S -> G 
(polymorphism confirmed at protein FT level;dbSNP:rs11546426).

VARIANT 74 74 K -> R 
(polymorphism confirmed at protein FT level; dbSNP:rs10904516). 

SQ SEQUENCE 146 AA; 15893 MW; 70746291268494CC CRC64; 
MAGELTPEEE AQYKKAFSAV DTDGNGTINA QELGAALKAT GKNLSEAQLR KLISEVDSDG 
DGEISFQEFL TAAKKARAGL EDLQVAFRAF DQDGDGHITV DELRRAMAGL GQPLPQEELD 
AMIREADVDQ DGRVNYEEFA RMLAQE 

※ちなみに、ヒトの有名なカルモジュリンは、CALM_HUMANで、CALL5とは50%ほどの
配列一致率。

二つの変異体がUniProtに記載されている



アミノ酸配列の取得と検索
1) Googleで”UniProt“と入力 2) UniProtのページのフォームに”CALL5_HUMAN“と入力

3) CALL5_HUMANのページ
４) メニューの[Format]から”FASTA(canonical)”を選ぶ

5)一文字表記のアミノ酸配列が表示される。
これをマウスで選択し、コピーする。



PDBjによる相同な立体構造（鋳型構造）の検索
1) Googleで”PDBj“と入力 2) PDBjのトップページから”Sequence Navigator”を選択

3) [Search by sequence]のタブを選び、
フォームに、UniProtのページでコピーし
たCALL5_HUMANの配列をペースト

4) 対PDBの
BLAST検索の結
果が表示される。
PDBコード“1ahr”
のA鎖が、
sequence identity 
51%でヒット。

→これを鋳型とする



Chimera：鋳型構造の読み込み
1) Chimeraを起動して、メニューから [File]→[Fetch by ID…]を選ぶ。

2)  [PDB]を選択、IDのフォームに”1ahr”と入力し、[Fetch]をクリック。

3)  左図のような構造が表示

されるはず。緑色の球はカル
シウムイオン。

4) メニューから[Tool]→[Sequence]→[Sequence]  を選ぶ。と以下の
ようなSequenceウィンドウが表示される。



Chimera：標的配列の読み込み
1) Sequenceウインドウのメニューから [Edit]→[Add Sequence…]を選ぶと

Add Sequenceのウィンドウが表示される。

2) Add Sequeceウィンドウから、[From UniProt]の
タブを選択し、UniProt name/IDのフォームに、
“ CALL5_HUMAN ”と入力し、[OK]をクリック。

3) 以下のような構造(1ahr)と配列(CALL5_HUMAN)
のアラインメントが表示される。



Chimera:変異箇所の立体構造の確認
VARIANT 58 S -> G (polymorphism confirmed at protein FT level). 

MAGELTPEEE AQYKKAFSAV DTDGNGTINA QELGAALKAT GKNLSEAQLR KLISEVDSDG 
DGEISFQEFL TAAKKARAGL EDLQVAFRAF DQDGDGHITV DELRRAMAGL GQPLPQEELD 
AMIREADVDQ DGRVNYEEFA RMLAQE 

1) 58番目のS (VDSDG)を探し、それに対応する構造部位（この場合はA）をマウスで選択する。

2) 選択された状態で、
[Actions]→[Atoms/Bonds] →[Show] 
とすると、選択された構造部位がスティ
ック表示される。

SNPが報告されている 58番目のS (S->G)の立体構造上の位置を確認してみる。

※同様に74番目のK -> R 
の位置も確認してみる



Chimera:標的配列のCa2+結合部位の推定
鋳型立体構造(1ahr)のCa2+イオンの結合部位を求め、sequenceウィンドウで対応する標
的配列の部位を確認すればよい。

1) メニューから[Select]→[Residue] →[CA]を選択し、
Ca2+イオンを選択。

2) メニューから[Select]→[Zone…] を選択する。

3) Select Zone Parameterのウィンドウが表示される。
一番上のフォームの”5.0”を”4.0”に書き直して、[OK]
をクリックする。

4) 選択された状態で、 [Actions]→[Atoms/Bonds] 
→[Show] で、 Ca2+結合部位がスティック表示される。

5) 選択された状態で、 sequenceウィンドウを確認す
ると、 Ca2+結合部位が緑色で強調表示されている。



Modellerによるホモロジーモデリング(1)
1) sequenceウィンドウから[Structure]→[Modeller(homology] 
を選択

2) Modellerウィンドウの、Choose the targetを”CALL5_HUMAN”とし、
Choose at least one template：を1ahr(#1) chainAを選択する。

3) [Advanced Options]をクリックし、
[Number of output models]を１とし、
[Include non-water HETATM residues
from template]を☑する。



ローカルにModellerを起動するための注意
Location of Modeller executableを設定する必要があります。

C:¥Program Files¥Modeller9.14¥lib¥x86_64-w64¥mod9.14.exe

デフォルトではmod9v9に
なっていますが、このままでは
動きません。

Windowsの場合の設定例

※バージョンやインストール場所によって詳細は異なります。各自の設定に合わせてください。

[Browse]をクリックして
フォルダを移動し、
Modellerの
実行ファイルを選択

Macintoshの場合の設定例

/usr/bin/mod9.14

[Browse]をクリックして
フォルダを移動し、
Modellerの
実行ファイルを選択



Web Serverを利用する場合
ローカルのModellerを起動できない場合、 Chimeraの開発グループが用意した
Web serverを利用することができます。

アカデミックライセンスの
ライセンスキー文字列を
入力する必要があります。

アカデミックの方が、ライセンス
キーを取得するには
http://salilab.org/modellerにア
クセスし、[Registration]から、

ユーザー情報を入力してくださ
い。しばらくすると、ライセンス
キーの文字列が電子メールで
送付されます。

※Web Serviceを利用した場合も、ローカルに起動した場合も以後の手続きは同じです。



Modellerによるホモロジーモデリング (2)
4) Modellerウィンドウの下の[OK]をクリックすると、計算が開始する。

計算終了までは１分～数分かかる。計算進行状況は、画面左下に表示される。

5) 計算が終了すると、鋳型構造とモデル構造が表示される。

6) [Favorites]→[Model Panel] を選択

Model Panelウィンドウの[Shown]の☑のオン・オフで、オブジェクトの表示・非表示を選択可能。

鋳型構造(1ahr) モデル構造(1ahr)



Modellerによるホモロジーモデリング (3)
7) [File]→[Save PDB…] を選択すると
、[ 

8) 適当なフォルダとファイル名
（”CALL5_HUMAN.pdb”）
を入力

9)Save models:
では、保存したモデル
（”CALL5_HUMAN model 1 (#1.1)”）
を選択

10) [Save]をクリック

最後に、モデリングした構造だけを、PDB形式のファイルに保存する



UCSF Chimeraだけで実行できる解析
・リガンド分子と近接している残基の同定
・指定した原子間の距離の計測
・分子表面の表示
・静電ポテンシャルによる分子表面の色付け
・アミノ酸配列と立体構造とのアラインメント
・進化的保存が高い部位の立体構造上の位置の観察
・アミノ酸置換構造のモデリング
・相同な二つの立体構造の比較
・モーフィングアニメーション

見てわかる 構造生命科学―生命科学
研究へのタンパク質構造の利用―
中村春木 編 化学同人 税抜5000円 RasMol,  
UCSF Chimera, PyMOLの使い方を解説

操作法が
載っています

その他にも以下のようなモデリングに関する機能が
あります

・水素原子の付加 [Tools]→[Structure Editing]→[AddH]
・部分電荷の付加 [Tools]→[Structure Editing]→[Add Charge]

・低分子ドッキングプログラム Auto Dock Vina の実行
[Surface/Binding Analysis]→[AutoDock Vina]

・ドッキング候補ポーズの解析 [Surface/Binding Analysis]→[ViewDock]



HOMCOSを用いた
複合体構造のホモロジー・モデリング



Cyclin-dependent protein kinase (CDK2)

ADP
Substrate Peptide
PKTPKKAKKL

Cyclin A2

複合体立体構造は
単量体構造より機能情報が豊富

複合体立体構造から以下のことがわかる
(1)他の分子との結合部位

→変異体の解釈・設計
→ 阻害剤の設計・改変

(2)結合・反応のメカニズムの理解 3D Complex of 
CDK2＋ADP
＋Cyclin A2 
+ Peptide
(PDBcode:3qhw)



鋳型ベースのモデリング:Template‐based Modeling
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既知の立体構造 予測立体構造

既知の立体構造 予測立体構造

複合体のホモロジー・モデリング



鋳型ベースのドッキング:Template‐based Docking
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HOMCOS :複合体立体構造の検索・ホモロジーモデリングのサーバ

サービス 入力１ 入力２

PDB内の

結合分子
の検索

タンパク質に対する
結合分子の検索

アミノ酸
配列

化合物に対する
結合分子の検索

化合物
構造

複合体

立体構造
の
ホモロジー
モデリング

ホモ多量体モデル アミノ酸
配列

ヘテロ多量体モデル アミノ酸
配列A

アミノ酸
配列B

化合物ータンパク質
複合体のモデル

アミノ酸
配列

化合物
構造

・PDB内の複合体の立体構造データを検索し、それを鋳型にモデリングする

・配列相同性検索はBLAST、化学構造類似性検索はKCOMBUを使用

MYB

HRX
Crebbp

MYB

MRE-1

MRE-1

http://homcos.pdbj.org“HOMCOS”でグーグル検索 ⇒

アミノ酸配列２本を入力、それぞれ、PDBに
対するBLASTを実行

ヘテロ多量体のモデリング

タンパク質に対する結合分子検索

化合物－タンパク質複合体のモデル
アミノ酸配列と化合物構造を入力、アミノ酸配列はBLASTで、
化学構造はKCOMBU   でPDBに対して検索

BLAST BLAST 

BLAST KCOMBU 

鋳型構造

鋳型構造

予測構造 予測構造



テンプレート
構造

ステップ１：フォールド認識 ステップ２：モデリング

予測対象配列
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テンプレート構造とそのアライメント

ホモロジー・モデリングによる３次構造予測

立体構造データベースの中から、クエリ配列に

最も適合する構造（テンプレート構造）を探す

テンプレート構造に従って全原子を構築
（１）側鎖原子の構築
（２）挿入ループ部を構築

BLAST,  プロフィール法, スレディング法…. MODELLER, FAMS, ….

HOMCOS が提供するサービス



タンパク質に対する結合分子の検索

>1vwg_A

>1jsu_B

2g9xA
1w98A
1fq1B
:

問い合わせ配列

問い合わせ化合物

1vwg_1 A1 B1
2g9x_1 A1 B1
:

KCOMBU検索

BLAST検索

TGWVEIEINL…

コンタクトしている分子の表

SHL
C39
GBC
:

類似した化合物のリスト

相同なタンパク質のリスト

SHL

GBC

C39

1vwg_1 A1 B1
2g9x_1 A1 B1
:

コンタクトしている分子の表

問い合わせ配列とコンタクトする
分子の予測リスト

問い合わせ化合物とコンタクトする
分子の予測リスト

化合物に対する結合タンパク質の検索

PDBに登録された
アミノ酸配列の
データベース

PDBに登録された
化合物の
データベース



CDK3を題材をした結合分子予測

1) Googleで”HOMCOS“と入力 2) 「タンパク質に対する検索」を選ぶ

3) UniProtIDのフォームに
“CDK3_HUMAN”と入力して、
[SEARCH]をクリックする。

問い合わせ蛋白質の配列は以下の４通りで入力可
(i) PDB_ID+鎖 (ii) PDBファイルのアップロード
(iii) UniProt ID  (iv) アミノ酸配列

CDK3_HUMAN  (Cyclin-dependent  kinase 3)



「タンパク質に対する検索」結果のトップ画面(CDK3)
・単量体、複合体構造は、デフォルトでは代表構
造だけがバー表示されている。アライメント領
域・相互作用部位によって代表を決めている。

・相同性のしきい値は、デフォルトではE-
value<0.001だけで、同一残基率は0%に設定してあ
る。よりしきい値を上げれば（30%,40%,…,95%）、候
補構造は減るが、予測の信頼性は向上する。・全ての相同な立体構造を表示する場合は、

[bars:full]をクリックする。

のアイコンをクリックすると単量体
の立体構造モデルが表示される



単量体立体構造の表示(CDK3)
Sequence-replaced 3D model（簡易ホモロジーモデル構造）：

鋳型構造と座標は同じ。残基名と残基番号を標的配列と入れ替え
てある。側鎖原子や挿入残基は正しくモデリングされていない。

クエリ(CDK3_HUMAN)
と鋳型(1fin_C_1）との
アラインメント

簡易ホモロジーモデル構造の
ダウンロード

鋳型構造の
ダウンロード

をクリックすると、
生物学的単位に含まれる
全ての分子が表示される

をクリックすると
Modellerの入力ファイルを
ダウンロード可能。
Modellerをインストールす
れば、全原子のモデルが構
築可能

CDK3
（鋳型はCDK2）

メニューから

表示される構造
の種類を選ぶこ
とができる



Contact Barのヘテロ複合体の画面(CDK3)

相互作用部位

標的分子と鋳型の同一残基率(%)
値が高いほど予測の信頼性が高い

コンタクトしている別の
タンパク質の分子名

のアイコンをクリック
すると
ヘテロ複合体の
立体構造モデルが
表示される



ヘテロ複合体立体構造の表示(CDK3)

CDK3
（鋳型はCDK2）

Cyclin A2

予測接触残基
標的配列(CDK3)の
残基番号、残基名に
なっている。

接触残基が’b’
の文字で示さ
れている。

複合体のSequence-replaced 
model、鋳型構造のダウンロー
ド、Modellerの入力ファイルの
ダウンロードも同様に可能

CDK3

Cyclin A2



Contact Barの化合物複合体の画面(CDK3)

相互作用部位

標的と鋳型の同一残基率(%)
値が高いほど予測の信頼性が高い。

4QE, 4SPなどはPDBの３文字表記の分子名

コンタクトしている
化合物の分子名

のアイコンをクリックすると
化合物－タンパク質複合体の
立体構造モデルが
表示される



化合物－タンパク質複合体(CDK3)

化合物名。
３文字表記は4QE

予測接触残基

標的配列
(CDK3)の
残基番号、残基
名になっている。

接触残基が’b’の文字で示されている。

CDK3
（鋳型はCDK2）

複合体のSequence-replaced 
model、鋳型構造のダウンロー
ド、Modellerの入力ファイルの
ダウンロードも同様に可能



Site Table
コンタクトバー表示の画面上のこのアイコンをクリック

UniProtのアノテーション
(Feature Table)結合分子のサマリー

相同配列群のアミノ酸頻
度。頻度順にソート。出現
したアミノ酸だけ表示

二次構造(H:αへリックス、E:βシート)

溶媒露出度(%)

をクリックすると特定のサイトのまとめのページが表示される

(1) 埋もれている部位（溶媒露出度accが
小さい部位）に変異が入ると、天然構造が
不安定になり、機能を失活しやすい。

(2) 相同タンパク質群で観察されるアミノ酸の割合（observed aa）が大

きい（よく観察される）アミノ酸に変異した場合、機能への影響は小さい。
逆に、稀にしか観察されないアミノ酸に変異した場合は、機能を失いや
すい。SIFT scoreなど多くのプログラムがこの原理に基づく。



3番目の部位のまとめ(CDK3)

相同配列群のアミノ酸頻度。
頻度順にソート。出現した
アミノ酸だけ表示

これらのPDBのIDをクリックすると、この部
位（3番目の部位）を結合サイトとする複合
体立体構造のモデルが表示される。



３番目の部位がタンパク質間相互作用部位
となる例(CDK3)

Cyclin A2

３番目のMet
(鋳型ではAsn)

CDK3
(鋳型は
CDK2)



SPIC_HUMANの場合の
「タンパク質に対する検索」のトップ画面

のアイコンをクリックすると核酸－タンパク質複合
体の立体構造モデルが表示される

SPIC_HUMAN  (Transcription factor Spi-C)



核酸タンパク質複合体(SPIC)
デフォルトでは一つの標的タンパク質と一
つの結合分子が一対一で表示される。

二重鎖ＤＮＡのように、必ず２分子がセット
になる分子ではおかしなことになる。

をクリックすると、このPDBの
生物学的単位(Biological Unit) 
assembly_id=1に含まれる全分
子が表示される。



核酸タンパク質複合体(SPIC)

をクリックすると、このPDBの
生物学的単位(Biological Unit) 
assembly_id=1に含まれる全分
子が表示される。

assembly_id=1の生物学的単
位に含まれる全分子
を用いたモデル



ARSA_HUMANの場合のSite Tableの画面

UniProtのアノテーション
(Feature Table)結合分子の

サマリー

相同配列群のアミノ酸頻
度。頻度順にソート。出現
したアミノ酸だけ表示

溶媒
露出
度(%)

UniProtの変異体に
関する情報(VARIANT)

をクリックすると特定のサイトのまとめのページが表示される

(1) 埋もれている部位（溶媒露出度accが
小さい部位）に変異が入ると、天然構造が
不安定になり、機能を失活しやすい。

(2) 相同タンパク質群で観察されるアミノ酸の割合（observed aa）が大

きい（よく観察される）アミノ酸に変異した場合、機能への影響は小さい。
逆に、稀にしか観察されないアミノ酸に変異した場合は、機能を失いや
すい。SIFT scoreなど多くのプログラムがこの原理に基づく。

ARSA_HUMAN(Arylsulfatase A)



29番目の
部位の

まとめ
(ARSA)

D→Nの変異は、
Leukodystrophy 
metachromatic(MLD)
[リソソーム病(異染性白質ジ
ストロフィー)]という病気と関
連がある。

カルシウムイオン
(Ca2+)との複合体構
造が予測されている。

29番目のDの進化的保存は極めてよい(100%)



29番目の部位に注目した
Ca2+イオンータンパク質複合体の予測結合構造

Ca2+

29番目の部位のD→Nの変異によって
Ca2+イオンとの結合に影響が及ぶ可能性Ca2+

29番目の
Asp
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ヘテロ蛋白質複合体のモデリング

>1vwg_A

>1vwg_B

>2g9x_A

1vwgA
2g9xA
8atcA
1fq5A
:

1vwg_1 A1 B1
2g9x_1 A1 B1
1jsu_1 A1 B1
8atc_2 A1 B1
2fi5_1 E2 I1
:

BLAST 検索

BLAST検索
相同な複合体の一つを
鋳型として取り出す

鋳型構造：1vwg_1  A1 B1
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配列の
置き換え

TGWVEIEINL...

QLVVKTFAFT...

結合している
分子の表

1vwgB
2g9xB
2fi5I
2eufA
:

配列Bと相同な
タンパク質のリスト

配列Aと相同な
タンパク質のリスト

Template-based Model
(Sequence-replaced model)

予測モデル構造
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単量体の
重ね合わせ

Template-based docking

予測モデル構造

問い合わせタンパク質B

問い合わせタンパク質A
配列

単量体
構造

or

配列

単量体
構造

or

orPDB内のアミノ酸配列
のデータベース



ヘテロ多量体のモデリング(2本の配列から）

1) Googleで”HOMCOS“と入力 2) 「ヘテロ多量体のモデル」を選ぶ

CDK5_HUMAN： Cyclin-dependent proten kinase 5
CCNB1_HUMAN ：G2/mitotic-specific cyclin B1 

3) タンパク質AのUNIPROT_IDにCDK5_HUMANを
タンパク質BのUNIPROT_IDにCCNB1_HUMANを入力

問い合わせ蛋白質の配列は以下の４通りで入力可
(i) PDB_ID+鎖 (ii) PDBファイルのアップロード
(iii) UniProt ID  (iv) アミノ酸配列



ヘテロ多量体のモデリング（２本の配列から）

CDK5_HUMAN CCNB1_HUMAN

複合体のsequence-replaced 3D model

sequence-replaced model
template 3D structure
の二つを、表示・ダウンロード可能

配列Aと配列Bに
ついて、対PDBの
BLAST 検索が
実行される



Modellerによる二量体のモデリング(Win8)[1]

（１）モデル３Ｄ構造のウィンドウで をクリックする

HOMCOSのヘテロ多量体モデリングで、CDK5_HUMANとCCNB1_HUMANを入力し、適当な鋳型構造を選んで、以下のモデル３Ｄ構
造のウィンドウが表示されたとする。

（２）Modellerのスクリプトのページが表示される。

（３）スクリプトファイル (model_complex.py)、 アラインメントファイル(alignment_complex.ali),
鋳型構造のファイル(1h27_A_1_B_1.pdb)の三つを自分のパソコンにダウンロードする。
今回は、C:¥Users¥guest01¥Downloadsというディレクトリに保存することにする。



Modellerによる二量体のモデリング(Win8)[2]

(4)スタート画面の矢印をクリッ

クすると、インストールされたプ
ログラムの一覧が表示される。

(5)アルファベットのMのと
ころにある、“Modeller”と
いうコマンドプロンプトのア
イコンをクリックする

(6)このようなコマンドプロンプト
のウィンドウが表示される。

(7) コマンドのウィンドウ内で cd [ディレクトリ名] と入力し、「モデリング用ディレクトリ」（前頁

で三つのファイルをコピーしたディレクトリ）に移動する。
今回は、cd C:¥Users¥guest01¥Downloadsと入力する。



(8)コマンドdirを入力すると、現在のディレクト

リにあるファイルの一覧が表示される。ダウン
ロードした三つのファイルがあることを確認。

Modellerによる二量体のモデリング(Win8)[3]

(9) コマンドmod9.14 [スクリプトファイル]
を入力し、Modellerを実行する。今回は、
mod9.14 model_complex.py
と入力する。この後、計算終了までには
１分～数分程度の時間がかかる。

(10)計算終了後、再びコマンドdirを入力すると、出力ファイルの一
覧が表示される。このうち、query_complex.B99990001.pdbが
予測構造のＰＤＢファイルである。このファイルをChimeraなどで開き
、予測構造を確認する。



1) Googleで”HOMCOS“と入力 2) 「ヘテロ多量体のモデル」を選ぶ

4au8A： Cyclin-dependent proten kinase 5
2b9rA ：G2/mitotic-specific cyclin B1 

3) タンパク質AのPDB_IDに4au8, CHAIN_IDにA、
タンパク質BのPDB_IDに2b9r, CHAIN_IDにAを入力

問い合わせ蛋白質の配列は以下の４通りで入力可
(i) PDB_ID+鎖 (ii) PDBファイルのアップロード
(iii) UniProt ID  (iv) アミノ酸配列

ヘテロ多量体のモデリング(2つの単量体構造から）



配列Aと配列Bに
ついて、対PDBの
BLAST 検索が
実行される

4au8A (CDK5) 2b9rA (CCNB1)

template-based 3D docking model

ヘテロ多量体のモデリング（２つの単量体構造から）

sequence-replaced model
template 3D structure
template-based 3D docking model
の三つを、表示・ダウンロード可能
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化合物ータンパク質複合体のモデリング

>1vwg_A

2g9xA
1jsuA
1fq5A
8atcA
:

PDB内のアミノ酸配列
のデータベース

2g9x A1 B1(SHL)
1jsu A1 B1(C39)
8atc A1 B1(PLP)
2fi5 E2 I2(ATP)
:

KCOMBU 検索

BLAST検索 鋳型となる
複合体構造の選択

結合している
分子の表

SHL
C39
GBC
:

問い合わせ化合物と
類似した化合物のリスト

問い合わせ配列
と相同なタンパク質のリスト

PDB内の化合物の
データベース
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※問い合わせ化合物はfkcombuを用い
フレキシブルに鋳型化合物に重ね合わせる

SHL

GBCC39

SHL

TVAWGKTDLQL…

鋳型：2g9x_A1 B1
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Template-based Model
(Sequence-replaced model)

予測モデル構造

Template-based docking
予測モデル構造

>1vwg_B

>2g9x_A

配列の
置き換え

単量体の
重ね合わせor



化合物タンパク質複合体モデリング
のページ

2) 「化合物タンパク質複合体のモデル」を選ぶ

3) PROTEINのUNIPROT_IDにはCDK3_HUMANを
COMPOUNDのPDB three letter ligand codeにはIREを入力

Iressa/Gefitinib (IRE)

1) Googleで”HOMCOS“と入力



化合物ータンパク質複合体のモデリング

アミノ酸配列対PDBのBLAST 検索、
化合物 対PDBのKCOMBU検索
が実行される

標的化合物(IRE) 鋳型化合物(DTQ)

複合体のモデル構造が表示される

鋳型化合物(DTQ)

標的化合物(IRE)


